locked
Failed with Workbooks.Open RRS feed

  • Question

  • User-144431078 posted

    Does anyoneknow why IIS7 can´t open Excel or Word Applications with ASP?

    Set xl=CreateObject("Excel.Application") is not giving Error, but Set wb=xl.Workbooks.Open("File.xls") yes.

    This code works O.K. with IIS6.

    The error descriptions talks about Resources, but where are those resources? 

    Wednesday, May 2, 2007 11:14 AM

Answers

All replies

  • User157784788 posted

     

    Look at event logs, there should be DCOM related error thrown up / may be event id 10016.

    This is most probably related to local launch and activation permissions for IUSR and Excel.

    Visit following link:
    http://www.microsoft.com/technet/support/ee/transform.aspx?ProdName=Windows%20Operating%20System&ProdVer=5.2&EvtID=10016&EvtSrc=DCOM&LCID=1033

    HTH.

    ~ Ganesh

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Thursday, May 3, 2007 12:19 AM
  • User-144431078 posted

    SOLVED!!!!!!!!!!!!!!

     

    Friday, May 4, 2007 11:27 AM
  • User1073881637 posted
    And the solution was?  The link listed below?
    Saturday, May 5, 2007 2:58 AM
  • User-876753106 posted
    Hello,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" /><o:p></o:p>I am facing the same problem with IIS 7 on windows 2008, the same error when trying to open an excel workbook, I really tried a lot of things from DCOM setting to change users access on the excel file folder.<o:p></o:p>So please if you can guide me to the solution you found I will be thankful, i am really desperate to solve this in a very short time.<o:p></o:p> <o:p></o:p>

    Thanks. 

    Saturday, June 13, 2009 8:43 AM
  • User-200279315 posted

     HI

     i have exactly the same problem (IIS 7,5, windows server 2008 RC2). I dont see excel (or the corresponding clsid) under component services, so i dont understand how i can modify the needed rights. I believe under Windows 7 and Windows server 2008, it does not work the same way as under XP

    Tuesday, August 2, 2011 12:21 PM
  • User-200279315 posted

     Hi

    I found the solution. See

    http://www.sevenforums.com/microsoft-office/56884-microsoft-excel-application-entry-missing-dcomcnfg.html

    Wednesday, August 3, 2011 4:31 AM
  • User-200279315 posted

    Here the solution (same solution in link entry posted previously):

     

    I found the solution. I have to give dcom rights to excel(office). Here is what to do on windows 7 and windows server 2008:

    1. go to DCOMCNFG (component services)
    2. In the left tree structure, right click on My Computer and select Properties
    3. Click on COM SECURITY tab
    4. Give Permissions to Network Service and Users in the "Access Permissions" and "Launch and Activation Permissions" by clicking the Edit Default buttons.

     

    Wednesday, August 3, 2011 4:35 AM
  • User-1672167363 posted

    Hi @ knoepdan1,

    Glad that you got it worked out.

    I have a suggestion. Since this is old and did not help you.

    Since you have an updated solution maybe create new thread put in the topic "Solved" and your information.

    Then the next time it will save a user some time.

    Just a thought.

    Martin

     

    Wednesday, August 3, 2011 6:38 AM
  • User-200279315 posted

    Hi

    The solution for Windows Server 2008 posted above did not work properly :-( 

    Having given the rights to the NetworkService account (and the account of the application pool) i could create excel reports in the asp.net application via Excel. Unfortunately, today, it no longer works and the same error occurs. I checked the rights and they are the way they should be.

    There must be another setting affecting the outcome :-(

    Thursday, August 4, 2011 10:53 AM
  • User-1672167363 posted

    Hi @ knoepdan1,

    Since the OP Thread had an answer and it does not work for your

    case then the best choice would be start a new thread

    and information for your system and information from IIS Server logs.

    Then users can help your special situation.

    Martin

     

     

     

    Thursday, August 4, 2011 11:01 AM
  • User-200279315 posted

    I opened up a new thread as a) this thread is old and b) it concernes a a more specific problem:

     

    http://forums.iis.net/p/1180514/1991458.aspx#1991458

    Thursday, August 4, 2011 11:16 AM
  • User-2055648946 posted
    so so, after so much search, i resolved doing it!!! Please make this folder. C:\Windows\SysWOW64\config\systemprofile\Desktop u need, create this folder, and set your working folder to it, evetthing work here :) 20 hors so so searching....
    Sunday, April 8, 2012 9:38 PM