locked
A theme with the name "THEMENAME 1011" and version already exists on the server. RRS feed

  • Question

  • I am working with a custom theme packed in a feature as part of a solution and I keep getting this error message. I have tried deleting the _them folder and setting unique codes in the inf file and it hasn't worked. Most importantly, I like to understand what causes this problem and how I can prevent it.

    Thanks,

    mike

    Wednesday, April 13, 2011 11:13 PM

Answers

All replies

  • Hi,

    I think you have missed out any step. try to follow below link

    http://www.yanndechamplain.com/2006/08/28/creating-a-theme-for-wss-and-error-a-theme-with-the-name-themeid-1011-and-version-already-exists-on-the-server/

    let us know if it works

     


    Cheers, Hemendra-MCTS "Yesterday is just a memory,Tomorrow we may never see"
    • Marked as answer by Leoyi Sun Thursday, April 21, 2011 9:19 AM
    Thursday, April 14, 2011 5:36 AM
    Moderator
  • Try this:

    Go into SharePoint Designer and open the subsite. Under the _theme folder, delete the folder for the theme you just created.

    then open the site it  . GO to site settings> site theme > select your theme

    #Note: Do not delete the themes.inf file


    Dare to promise
    Friday, April 15, 2011 7:24 PM
  • Few steps to resolve this issue
    Remember Themes are case sensative.
    Themes INF file should have the smae name as theme name(Ref folder location 12/templates/themes/themename)
    Edit the inf file and give the same title as the theme name
    SPThemes.xml should have an entry for the newly created theme
    (Ref Location 12/templates/layouts/1033/sptheme.xml)

    Note : Exact theme folder name should be use in xml and inf file as it is case sensitive.

    Tuesday, May 3, 2011 7:34 AM