SSIS 2005 not running after upgrading (32 bit, Windows XP to 64 bit Windows 7) RRS feed

  • Question

  • I really need some help. Recently I went from using Visual Studio and SQL 2005 on a laptop (32bit system - Windows XP) to a desktop unit 64bit processor with Windows 7). SSIS on the laptop worked just fine and I could execute and open packages in SSIS; however, my new desktop unit will not even allow me to open a new package or run an existing package. As soon as I attempt to create a new SSIS project, I receive the following error: "An error prevented the view from loading. The specified module could not be found. (Exception from HResult:0x8007007E)(System Windows Forms).

    SSIS won't allow me to view the control flow or data flow screens and if I attempt to run an existing package created with the SSIS wizard I receive the following error: SSIS package "Package1.dtsx" starting.
    Information: 0x4004300A at Data Flow Task, DTS.Pipeline: Validation phase is beginning.
    Error: 0xC0202009 at Package1, Connection manager "SourceConnectionExcel": SSIS Error Code DTS_E_OLEDBERROR.  An OLE DB error has occurred. Error code: 0x80040154.
    An OLE DB record is available.  Source: "Microsoft OLE DB Service Components"  Hresult: 0x80040154  Description: "Class not registered".
    Error: 0xC020801C at Data Flow Task, Source - Without_Sample$ [1]: SSIS Error Code DTS_E_CANNOTACQUIRECONNECTIONFROMCONNECTIONMANAGER.  The AcquireConnection method call to the connection manager "SourceConnectionExcel" failed with error code 0xC0202009.  There may be error messages posted before this with more information on why the AcquireConnection method call failed.
    Error: 0xC0047017 at Data Flow Task, DTS.Pipeline: component "Source - Without_Sample$" (1) failed validation and returned error code 0xC020801C.
    Error: 0xC004700C at Data Flow Task, DTS.Pipeline: One or more component failed validation.
    Error: 0xC0024107 at Data Flow Task: There were errors during task validation.
    SSIS package "Package1.dtsx" finished: Failure.

    I have tried changing the properties in the package to run in 32-bit mode; however, this does not work. I can run queries and import data in SQL Server Management Studios just fine, as well as run queries and reports in Visual Studios; however, I can't execute or create any package in Visual Studio with the new machine. Am I missing a needed system file in the new sysWOW64 folder? The IT person who installed the software isn't familiar with the program and doesn't know how to fix it either. I'm relatively new with using SSIS and really need some help on how to get this fixed. Any help you can offer would be greatly appreciated.

    • Edited by simpson213 Wednesday, August 6, 2014 4:40 PM
    Wednesday, August 6, 2014 4:34 PM


All replies