locked
500 Internal Server Error when downloading files if file name has some Japanese characters RRS feed

  • Question

  • Hi,

    I'm using the Live Connect API to download a file using a GET request to https://apis.live.net/v5.0/<file id>/content

    I'm trying to download a file named: 武蔵小山工程(再地区変更).xlsx    

    I get a redirect to: 

    http://storage.live.com/s1p-FXtnz2OztK7hILBibrz58BpCkU70R2pFfOwmFth-XTiXbwRSQhW5q-VGrtFKMR1Y8wnc1Doqy08YVJ0yDB0IxZWnObexCgAZfP0leQ7sS76PIozNio08uFrgKoVo7p9/%E6%AD%A6%E8%94%B5%E5%B0%8F%E5%B1%B1%E5%B7%A5%E7%A8%8B%EF%BC%88%E5%86%8D%E5%9C%B0%E5%8C%BA%E5%A4%89%E6%9B%B4%EF%BC%89.xlsx:Binary,Default/%E6%AD%A6%E8%94%B5%E5%B0%8F%E5%B1%B1%E5%B7%A5%E7%A8%8B%EF%BC%88%E5%86%8D%E5%9C%B0%E5%8C%BA%E5%A4%89%E6%9B%B4%EF%BC%89.xlsx

    and when I request this url I get the 500 Internal server error

    I don't know Japanese but I tried variation of this file name and for some I was able to download the file successfully.

    Thanks for your help

     

    Sunday, January 29, 2012 2:51 PM

Answers

All replies

  • Could you please specify the varied name for which it worked fine.

     

    This way it would be easy to find the list of characters for which this fails, if at all the issue is with some characters of language.

    Monday, January 30, 2012 5:14 PM
    Moderator
  • I tried the first character and then the first two, both worked fine. But when I added the third it didn't work. I also tried the characters between brackets and also worked fine.

    I tried to just remove the third characters but others caused the same problem. I understand the Japanese alphabet has lots of characters so trying them one by one is not an option for me :)

    Maybe just start with understanding what caused the internal error and that should lead to the root cause.

    Thanks

    Monday, January 30, 2012 5:35 PM
  • Hi,

    Thank you for the info! We have a positive reproduction of this issue and I'm working with the people who are responsible for the failing code to see if we can figure out a fix.

    I'll report back once I know more.

    Monday, January 30, 2012 7:40 PM
  • Hi,

    This bug should be fixed now :-)

    Thursday, February 16, 2012 12:27 AM