none
SYSPREP Issue : After sysprep and reboot, system reverts outbox driver to inbox RRS feed

  • Question

  • Hi All,

    I am working on a Virtual Bus driver. I am facing issue with sysprep.

    For my driver, there are INBOX drivers already part of Windows server 2016. When I connect device, INBOX drivers are loaded.

    I will update the drivers with latest OUTBOX drivers. And preparing system with help of SYSPREP tool.

    Once I run sysprep tool and restart server, my Virtual bus driver (only sys file gets reverted in system32\drivers folder) is getting reverted to INBOX versions.

    Please help me.

    regards,

    Prakash.

    Friday, November 24, 2017 2:08 PM

All replies

  • What in Box virtual bus driver is out ranking your driver? If you install your driver at runtime, will it out rank the in Box driver or must you force install it?

    d -- This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, November 24, 2017 5:24 PM
  • Hi Doron Holan,

    In general, I will update inbox driver with my recent built outbox drivers. This will sustain if I will not try to create system image with SYSPREP tool.

    After updating inbox drivers with outbox(recent built) drivers and create system image with SYSPREP, driver file in system32\drivers folder will get rollback to inbox SYS file.

    In the setupapi.setup.log, SYSPREP generalize option is updating all the installed packages. during which, it is considering the inbox driver update and it is NOT considering the latest updated driver.

    Regards,

    Prakash.

    Monday, November 27, 2017 5:31 AM
  • What specific driver are you trying to replace?

    d -- This posting is provided "AS IS" with no warranties, and confers no rights.

    Monday, November 27, 2017 2:24 PM