none
Visual Studio 2015 crashes all the time

    Question

  • I must say in advance that I am quite a fan of VS, but I am very disappointed experiencing increasing instability with every new edition of VS. 

    Before VS 2013 I can't remember seeing it crashing, but with the advent of 2015 (update 3 also applied) I experience continuous problems. For instance I load a solution, build it, run it and when I open another one VS always crashes. Very frustrating. 

    I take the opportunity to also complain about Python Tools for VS. When my Python project - haha, not even a project just a single code file - imports larger packages such as Cisco YDK, VS is unable to refresh the intelli-sense DB, eats up almost all memory it can find until runs out of memory and the corresponding process (can't remember its name exactly) crashes.

    I'd be very grateful to get back the robustness of VS I got used to.


     
    • Edited by Lac Thursday, August 11, 2016 4:31 PM
    Thursday, August 11, 2016 4:31 PM

Answers

  • To second my previous post, here is a nice example : System.NullReferenceException  when I tried searching my code.


    Have you tried reinstalling Visual Studio? It looks like WPF library error. 

    First, try to run visual studio in safemode:

    devenv /SafeMode

    https://msdn.microsoft.com/en-us/library/ms241278.aspx

    See if that works. It disables third-party extensions momentarily. 

    If you could run it, it is probably a problem with your extensions. I recommend reinstalling it or removing and installing it completely. 

    Also, when in safe mode, try backing up your settings using Tools->Import and Export settings (Make sure your setting is in effect in safemode before backing it up).

    If it didn't run in safemode:

    I suggest you reinstall Visual Studio to make sure all the libraries are correctly in place. You won't lose your custom settings in that way.

    You may then have to uninstall it in order to make it work.


    Saturday, August 20, 2016 1:59 PM

All replies

  • I must say in advance that I am quite a fan of VS, but I am very disappointed experiencing increasing instability with every new edition of VS. 

    Before VS 2013 I can't remember seeing it crashing, but with the advent of 2015 (update 3 also applied) I experience continuous problems. For instance I load a solution, build it, run it and when I open another one VS always crashes. Very frustrating. 

    I take the opportunity to also complain about Python Tools for VS. When my Python project - haha, not even a project just a single code file - imports larger packages such as Cisco YDK, VS is unable to refresh the intelli-sense DB, eats up almost all memory it can find until runs out of memory and the corresponding process (can't remember its name exactly) crashes.

    I'd be very grateful to get back the robustness of VS I got used to.


     

    Hi Lac,

    I suggest trying to reset the user data in order to avoid some hidden problems. Please run the following command from the visual studio folder using the command line:

    devenv /resetuserdata

    Please let us know if this solves the problem.


    • Edited by ManashtyMVP Thursday, August 11, 2016 4:47 PM
    • Proposed as answer by ManashtyMVP Monday, August 15, 2016 10:02 PM
    Thursday, August 11, 2016 4:46 PM
  • Hi Lac,

    Thank you for your post.

    Python is a third-party add-in to VS.

    1. You could try to restart Windows and in safe mode, run devenv /safemode in Visual Studio 2015 Command Prompt.

    If in safe mode this issue disappeared, the cause should be third-party applications, services or Visual Studio Add-ins.
    Please also try devenv /resetsettings or devenv /setup in Command Prompt.

    2. please go to Control Panel >Programs >Programs and Features
       Select Microsoft Visual Studio 2015 and click on 'repair'.

    If the error persists,  then you may try to running devenv.exe /log <log path> in Command Prompt, the log files will be generated in the <log path>.

    Then you can check and analyze the log file to see if there are anything incorrect.
    Besides, Please use http://aka.ms/vscollect   to gather the installation logs. After using it, you will find vslogs.zip from %temp% folder.
    Please upload the file to https://onedrive.live.com/   and share the link with us.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Friday, August 12, 2016 6:38 AM
    Moderator
  • Many thanks for the answer. To be honest, I'd be afraid of what exactly this commands resets as I have a couple of custom settings I don't want to lose.
    Saturday, August 20, 2016 1:46 PM
  • To second my previous post, here is a nice example : System.NullReferenceException  when I tried searching my code.

    Saturday, August 20, 2016 1:50 PM
  • To second my previous post, here is a nice example : System.NullReferenceException  when I tried searching my code.


    Have you tried reinstalling Visual Studio? It looks like WPF library error. 

    First, try to run visual studio in safemode:

    devenv /SafeMode

    https://msdn.microsoft.com/en-us/library/ms241278.aspx

    See if that works. It disables third-party extensions momentarily. 

    If you could run it, it is probably a problem with your extensions. I recommend reinstalling it or removing and installing it completely. 

    Also, when in safe mode, try backing up your settings using Tools->Import and Export settings (Make sure your setting is in effect in safemode before backing it up).

    If it didn't run in safemode:

    I suggest you reinstall Visual Studio to make sure all the libraries are correctly in place. You won't lose your custom settings in that way.

    You may then have to uninstall it in order to make it work.


    Saturday, August 20, 2016 1:59 PM
  • Thank you Lana Xu for the detailed answer.

    In fact, it is the devenv.exe process what crashes. Can you see the amount of memory consumed by devenv and PythonToolsAnalyzer in the screenshot ? Is that normal ?

    Saturday, August 20, 2016 2:03 PM
  • @Manashty, I'll give a try, thank you.
    • Edited by Lac Sunday, August 21, 2016 8:42 AM
    Saturday, August 20, 2016 7:41 PM
  • Hi Lac,

    Have you solved this issue successfully?

    If you have a good solution, how about sharing here?

    It will benefit other community members who encountered similar issue.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Monday, August 22, 2016 9:18 AM
    Moderator