none
Trigger Field Annotation (5010) RRS feed

  • Question

  • I have followed the instructions at http://msdn.microsoft.com/en-us/library/dd792702(BTS.10).aspx for adding a custom Element to my 837P (5010) Schema, unfortunately the trigger is not kicking in and my parsing is failing.

    All the exception message I get is

     

    Event Type: Error

    Event Source: BizTalk Server 2009 EDI

    Event Category: None

    Event ID: 4097

    Description:

    Fatal error encountered in EDI Disassembler, error information is Object reference not set to an instance of an object.

    How can I dig more to find out whats happening?

     

    Thanks

     

     


    SV

    • Edited by vai2000 Thursday, September 8, 2011 9:03 PM
    Thursday, September 8, 2011 9:02 PM

Answers

  • Can you attach your schema fragment? Is the element peer also triggered? Do you have the required element before an optional one?
    • Marked as answer by vai2000 Friday, September 9, 2011 2:49 PM
    Thursday, September 8, 2011 9:24 PM

All replies

  • Can you attach your schema fragment? Is the element peer also triggered? Do you have the required element before an optional one?
    • Marked as answer by vai2000 Friday, September 9, 2011 2:49 PM
    Thursday, September 8, 2011 9:24 PM
  • As Cris mentioned would help if you can give the schema segment
    Cheers,
    Bali
    MCTS: BizTalk Server 2010,BizTalk Server 2006 and WCF
    Blog: http://dpsbali-biztalkweblog.blogspot.com
    -----------------------------------------------------
    Mark As Answer or Vote As Helpful if this helps.
    Friday, September 9, 2011 7:12 AM