none
Wince 6: network bridging issue using intel 82574L RRS feed

  • Question

  • Hi all,
    I'm using WinCE 6.0 on a MSC COM Express board based on an Intel Atom platform (CPU: Z520PT; Chipset Intel US15W).
    The ethernet adapter is the Intel 82574L Gigabit Ethernet Controller.
    I'm stuck because I'm trying to set up a network bridge between the Intel controller and a PCI add-on ethernet adapter (I have tried different boards..) but I can't. The Intel controller is connected to our local area network whereas the add-on ethernet card is connected to a laptop: the laptop can't "see" our local network. Replacing the Intel adapter with another PCI ethernet card, the network bridge works fine!
    I can't understand if the Intel Driver for WinCE 6 (e1q51ce6.dll) supports "Network bridging".
    Theorically, that issue should concern the registry settings:

    [HKEY_LOCAL_MACHINE\Comm\MBridge]
    "DisplayName"="Microsoft Mac Bridge Miniport"
    "Group"="NDIS"
    "ImagePath"="MBridge.dll"
    ;"DisableSTA"=dword:01
    "Bind"=multi_sz:"PCI\\RTCENIC1","PCI\\E1Q51CE61"

    [HKEY_LOCAL_MACHINE\Comm\MBridge\Linkage]
    "Route"=multi_sz:"MBRIDGE1"

    [HKEY_LOCAL_MACHINE\Comm\MBridge1]
    "DisplayName"="Microsoft Mac Bridge Adapter"
    "Group"="NDIS"

    [HKEY_LOCAL_MACHINE\Comm\MBridge1\Parms]
    "BusNumber"=dword:0
    "BusType"=dword:0

    [HKEY_LOCAL_MACHINE\Comm\MBridge1\Parms\TcpIp]
    "EnableDHCP"=dword:0
    "IpAddress"="192.168.0.175"
    "Subnetmask"="255.255.255.0"

    [HKEY_LOCAL_MACHINE\Comm\PCI\E1Q51CE61\Parms]
    "ProtocolsToBindTo"=multi_sz:"MBRIDGE"

    [HKEY_LOCAL_MACHINE\Comm\PCI\RTCENIC1\Parms]
    "ProtocolsToBindTo"=multi_sz:"MBRIDGE"

    Any ideas?

    Please help me. Thanks in advance.

    Igor

    • Moved by Jesse Jiang Wednesday, May 25, 2011 6:52 AM (From:Windows Mobile Development)
    Monday, May 23, 2011 10:41 AM

All replies