Receiving 997 with segment terminator of hex value 15 RRS feed

  • Question


    I have multiple trading partners who uses a character that has the hex value of 15 on their 997 messages.  The messages are suspended becasue of a structural error.  Has anybody else had this problem?  I am currently using BizTalk Server 2006 R2.



    Wednesday, June 4, 2008 5:53 PM

All replies

  • How are you configured?  Do you have the party EDI properties Party as Interchange Receiver/ISA Segment Definition set with the Segment terminator set to Hex 15 and the Suffix set to None?


    Wednesday, June 4, 2008 6:02 PM

    For receiving X12 documents the Delimiter set including the Segment terminator are determined by the disassembler by parsing the ISA segment of the incoming message which is fixed length.  Are you having problems with other X12 files with hex 15 as seg terminator or just 997s?  If the error you are seeing says it is a structural error the disassembler may not have been able to successfilly parse the ISA segment.
    Wednesday, June 4, 2008 6:45 PM

    I have only seen the hex 15 on the 997s.  What would cause the disassembler to not be able to parse the ISA segment?



    Wednesday, June 4, 2008 6:56 PM
  • Have you configured the party to handle this Hex 15 as segment terminator?

    You can configure Segment Terminator character by following steps:

    1. Open EDI Properties

    2. go to X12 properties

    3. go to "party as interchange receiver"

    4. open ISA Segment Definition

    5. choose Segment Terminator as Hex 15.




    Thursday, June 5, 2008 10:54 AM



    Yes, I have tried that and it didn't fix the problem. 



    Thursday, June 5, 2008 2:38 PM
  • Under Party as Interchange SENDER, ACK Generation and Validation Settings, you might try

    Allow trailing separators

    Select to allow trailing delimiters and separators on the interchange sender so that they do not cause messages to be declared invalid.

    The default value is cleared.

    Create empty XML tags for trailing separators

    If you have selected Allow trailing delimiters/separators, select to create empty XML tags for each of the trailing separators.

    The default value is cleared.

    Friday, June 13, 2008 5:31 AM
  • JT77,


    Thanks for the idea, but that dosen't fix the problem.  It appears that the EDI Disassembler can not handle a character with the hex value of 15 as the segment terminator.


    Jason Mc

    Friday, June 13, 2008 11:03 PM
  • Houston, we have a problem....


    I am able to consume other schemas (namely 835) that have this segment terminator.  I have not tried it with the 997.  My party validation settings for the sender of these documents are the defaults.




    Saturday, June 14, 2008 6:11 AM