none
Linux OMSAgent not collecting from Apache/MySQL RRS feed

  • Question

  • I've installed the Log Analytics Agent on a on-premise server running Ubuntu LTS 18.04 with the generic LAMP package installed. There's nothing special about the installation and pretty much all the generic settings are used although some common Apache hardening has been applied.

    The agent reports back to Azure workspace just fine but I have the following issue.

    During the agent installation MySQL wasn't detected hence the extension wasn't installed. I've tried this a few times and every time MySQL is skipped as undetected. Is there a way to manually unpack and install the MySQL plug-in for the agent?

    Apache was detected during installation and the Apache OMS module has been enabled but not all Apache performance counter are reporting. All counters are reporting as zero (value = 0) except counters under the "Apache HTTP Server" object (e.g. Idle Workers = 5) but all other counters report zero (e.g. "Apache Virtual Host", Requests per Second = 0 )

    Any ideas on either problem?

    thanks in advance.

    Saturday, March 28, 2020 12:14 PM

All replies

  • Hi r00nster,

    See if  this and this helps. On the other hand, as shown below try to change / update configuration from portal end by adding all apache, mysql counters and then follow this troubleshooting doc section to see if it resolves your issue.

    Hope these inputs helps!

    Wednesday, April 1, 2020 6:25 AM
    Moderator