locked
Cannot install ASP.NET AJAX 1.0 on Windows 7 RRS feed

  • Question

  • User-1520668900 posted

    Hello,


    We've moved to Windows 7 Enterprise (x86), and now I'm not able to install ASP.NET AJAX 1.0 Extensions for ASP.NET 2.0. I've already installed IIS, Visual Studio (2003, 2005 & 2008).  I get the following error when I try to install AJAX Extensions:

    Microsoft ASP.NET 2.0 AJAX Extensions 1.0 requries the .NET Framework 2.0 or .NET Framework 3.0. The .NET Framework installer can be found on the website (http://go.microsoft.com/fwlink/?LinkID=76097). Please install a compatible version of the framework and try again.


    The problem is, that .NET Framework 2.0 is already installed as windows component (I get this message when I try to install .NET Framework 2.0).


    Can anyone help? Why doesn't the installer detect that ALL .NET Framework versions are already installed?


    Thanks in advance.

    Best Regards,
    Andreas

    Friday, January 15, 2010 6:22 AM

All replies

  • User-1853252149 posted

    Don't install AJAX, install ASP.NET 3.5 framework.

    Jeff 

    Friday, January 15, 2010 8:37 AM
  • User-1520668900 posted

    Yes, of course, I would use .NET 3.5 for new projects, and .NET 3.5 is already installed. But we have several existing projects in .NET 2.0 which use AJAX 1.0, therefor we still need it, till all projects are migrated to 3.5..
    Or is there a simple way to change these projects to use the 3.5 AJAX capabilities?


    Best Regards,
    Andreas

    Friday, January 15, 2010 8:51 AM
  • User-37927323 posted

    The extensions are included with 3.5 no need to install. What happens when you try and compile the app in windows 7?

    Friday, January 15, 2010 6:07 PM
  • User-1520668900 posted

    I have to add that it's a Visual Studio 2005 solution, not 2008. I cannot compile the project because of this error:

    Error    2    Die Datei oder Assembly "System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" oder eine Abhängigkeit davon wurde nicht gefunden. Das System kann die angegebene Datei nicht finden.

    Translation: File or Assembly [...] or one of its depedencies could not be found. The system could not find the file specified.


    Is there a solution unless migrating the projects (and all other) to VS 2008 / .NET 3.5?

    Monday, January 18, 2010 5:45 AM