locked
Visual Studio 2015 crashes on startup when trying to load Xamarin solution RRS feed

  • Question

  • User295875 posted

    I developed my Xamarin app entirely within VS2015, but recently whenever I try to open VS2015, it crashes on startup. VS2017 doesn't crash on startup, but is entirely unable to deploy to any iOS simulator, device, or even just an Ad Hoc build (see my other post about that if you think you can help there).

    Can anyone offer any guidance on how to get VS2015 to no longer crash on Xamarin solution load, so I can start making progress on my iOS project again?

    Wednesday, June 14, 2017 7:19 PM

Answers

  • User295875 posted

    I... may have figured out what's going on here. It looks like I had the solution open in VS2017 and tried to open it in VS2015 at the same time, and that caused VS2015 to crash. It would have been nice to have a more graceful failure or some kind of warning about what's going on (the under-the-covers bits that VS does is still pretty arcane to me), but after shutting down both VS versions, I just tried loading the solution in VS2015, and the IDE didn't crash. So it looks like maybe that was the culprit? At least it appears correlated; I'd have to do some more experimentation to substantiate it for certain.

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Wednesday, June 14, 2017 7:38 PM