none
OEM folders? RRS feed

  • Question

  • New to wes7

    I am a bit confused with the "oem folders" concept, I am trying to have this "MyApps" folder with sub folders how up on the Target image in "C:\MyApps\....". I am not being successful, the PathAndCredentilas looks OK.

     Where should I expect to see the MyApps folder on the the Target image? Right now it is in the AutoUnattend_Files folder.

    Thanks

     

    Tuesday, May 3, 2011 8:51 PM

All replies

  • You have to setup several sub folders, like so:

    %OEM% Folders\MyAppFolder\$OEM$\$1\MyApps

    MyApps will be in c:\

    It is a bit cryptic, but it works.

    -Sean


    www.sjjmicro.com / www.seanliming.com / www.annabooks.com, Book Author - ProGuide to WES 7, XP Embedded Advanced, WEPOS / POS for .NET Step-by-Step

    Tuesday, May 3, 2011 9:51 PM
    Moderator
  • Sean,

    Thanks, it worked....but why so cryptic?

    Wednesday, May 4, 2011 8:05 PM
  • It is how they architected it for big Windows. My guess: $OEM$ acts as a flag in the anser file (XML file) for custom items to be added to the image so IBE can install them.

    Someone from Microsoft can provide a direct reason.

    -Sean

     


    www.sjjmicro.com / www.seanliming.com / www.annabooks.com, Book Author - ProGuide to WES 7, XP Embedded Advanced, WEPOS / POS for .NET Step-by-Step
    Wednesday, May 4, 2011 10:03 PM
    Moderator
  • It's the TEXTMODE/GUIMODE (Setup) sytntax for OEM files. Small hint \$$\ is always the Windows Volume \$1\ will be the first Volume
    "Mark/Propose As Answer" if you got one.
    Thursday, May 5, 2011 12:03 PM