none
Word=Microsoft.Office.Interop.Word is not working in Windows Xp RRS feed

  • Question

  • I have developed a winform app using VS 2010 in windows server 2008 environment and that app consumed Word=Microsoft.office.Interop.Word. It is working fine in developed machine as application and setup. But the same setup it is not working in windows XP. I came to know while tracing the code is, Word._Application wordApplication = new Word.Application(); line is not executing and showing the exception like This File Could not be found.
    Could you pls let me know the solution.
    Advance Thanks,
    Linga Reddy
    • Moved by Fred Bao Monday, August 25, 2014 6:49 AM
    Saturday, August 23, 2014 12:35 PM

Answers

  • Hi  Linga,

    Which office version are you using ? The Excel Reference you add to your project will depend on the office you are using and that might cause the issue. Check this post for more info.


    Regards, Ram.

    Monday, August 25, 2014 6:36 AM
  • I think you have not referred word library to your project in windows XP, do you have Microsoft word installed on your machine ?
    Pl. do the following step to referred word library in your project
    1.  right click on solution explorer, click on Add reference and select COM tab
    2. Select Word com library (If you have word 2007 installed you will see 12.0 object library, if you have word 2010 installed you will see 14.0 object library and for word 2013 you will see 16.0 object library)
    3. Add reference, Now in reference folder of solution explorer you will see 'Microsoft.Office.Interop.word' library added.


    Hope it helps


    Ask me if you face any problem

    Monday, August 25, 2014 1:07 PM

All replies

  • ask in the Word for Developers forum... this assembly is not part of .Net Framework.


    Visual C++ MVP

    Saturday, August 23, 2014 2:57 PM
  • Hi  Linga,

    Which office version are you using ? The Excel Reference you add to your project will depend on the office you are using and that might cause the issue. Check this post for more info.


    Regards, Ram.

    Monday, August 25, 2014 6:36 AM
  • I'm using 2010 and XP machine also having 2010.
    Monday, August 25, 2014 12:38 PM
  • I think you have not referred word library to your project in windows XP, do you have Microsoft word installed on your machine ?
    Pl. do the following step to referred word library in your project
    1.  right click on solution explorer, click on Add reference and select COM tab
    2. Select Word com library (If you have word 2007 installed you will see 12.0 object library, if you have word 2010 installed you will see 14.0 object library and for word 2013 you will see 16.0 object library)
    3. Add reference, Now in reference folder of solution explorer you will see 'Microsoft.Office.Interop.word' library added.


    Hope it helps


    Ask me if you face any problem

    Monday, August 25, 2014 1:07 PM
  • Hi Linga,

    As koolprasad mentioned you should refer the right assembly for it to work as intended.

    Refer to this article at MSDN that explains this concept accurately.

    Hope this helps !! Cheers !


    Regards, Ram.

    Monday, August 25, 2014 2:59 PM
  • Hi Linga,

    From the error message that file not found, I agreed with the option of Ranachandran that the Office PIAs reference didn't correspond to the correct version of Word application you installed.

    Please check the reference as Koolpaasad2003 suggested, and if it didn't solove the problem please feel free to let us know.

    Best regards

    Fei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, September 1, 2014 9:34 AM
    Moderator