locked
Default Password for System Administrator RRS feed

  • Question

  • We recently downloaded and installed SQL Express as it was a required program for our new database management software.  When trying to install my database management software I was asked to Login to the SQL server.  I entered the SQLEXPRESS server, however, I do not have the SA password.  When SQL Express installed it did not ask for a password only for a user name and company.  I am running Windows Small Business Server with the Administrator and no password.  We did not assign a password to the Administrator account yet.

    I have tried to leave the password blank using the login SA and I get error message 28000 Login failed for user.  The user is not associated with a trusted SQL Server Connection.

    Is there a default password for SA?  Or in the alternative, how do I create a user or associate an exising Windows user with a trusted SQL server connection?


    Friday, November 16, 2007 4:04 PM

Answers

  • Currently your SQL Server is configured for Windows authentication thats why you are not able to login as SA.

    (a)  login to sql server using windows administrator privillaged user

    (b)  Change to Mixed mode. SQL Server --> Right click --> Select properties --> In server properties window ---> select security --> Select SQL Server & WIndows authentication --> apply

    (c) enable the SA login. Right click on SA --> Property --> enable login,

    (d) restart the service 

     

    Madhu

    Friday, November 16, 2007 4:24 PM

All replies

  • Currently your SQL Server is configured for Windows authentication thats why you are not able to login as SA.

    (a)  login to sql server using windows administrator privillaged user

    (b)  Change to Mixed mode. SQL Server --> Right click --> Select properties --> In server properties window ---> select security --> Select SQL Server & WIndows authentication --> apply

    (c) enable the SA login. Right click on SA --> Property --> enable login,

    (d) restart the service 

     

    Madhu

    Friday, November 16, 2007 4:24 PM
  •  

    To make it clearer... "sa" account is disabled by default in SQL Server 2005 and leaving its password blank is not recommended. SQL Server will let you leave it blank when you try to set it blank however it'll warn you about its risk.

     

    You can enable and use your "sa" login following the path Madhu drew for your.

    Monday, November 19, 2007 9:58 AM