locked
Multiple CGI/ FastCGI instances RRS feed

  • Question

  • User-529253680 posted

    Hi

     

    -        We have a wordpress site which was running under PHP version 5.3. We are using windows 2012 - IIS 8. (VPS )

    -        We upgraded PHP version from 5.3 to 5.6 few days back.

    -        After which we faced the issue ‘site hangs frequently. Regarding this when checked the task manager we noted that too many CGI/ FastCGI tasks were opened as in the screen shot - task-manager.jpg.

    -        We upgraded wordpress and plugin versions to the latest and removed unwanted plugins. But still the issue exists. Our wordpress version is 4.6.1. We have attached the screenshot regarding the plugins used - plugins-sierra-wp.png.

    -        We checked the settings as in http://www.iis.net/learn/application-frameworks/install-and-configure-php-applications-on-iis/using-fastcgi-to-host-php-applications-on-iis and everything was fine

    -        The screen shot of the error

    -        Then we switched back the PHP version to 5.3. Till now there is no issue (nearly about 7 hours) and we are continuously checking on this.

    Kindly suggest how to fix this

    Thanks

    Friday, September 9, 2016 9:02 AM

Answers

  • User-460007017 posted

    Hi sierratec,

    It seems that the problem comes from the error code"0x80070102"

    You could try the following steps:

    1.Go to

     %windir%\system32\inetsrv\fcgiext.ini 


    and locate the ActivityTimeout parameter; copy it into the [php] section. Change the parameter to whatever value you would like, and also make sure that it is not commented out. Restart IIS and you should be good.

    2.configure the activity timeout under server/IIS/FastCGI Settings/Edit in IIS Manager.

    Best Regards,

    Yuk Ding

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Tuesday, September 13, 2016 9:12 AM

All replies

  • User690216013 posted

    What's the specs of your VPS? Did you try PHP 7?

    Saturday, September 10, 2016 1:47 AM
  • User-529253680 posted

    We did not try PHP 7

    We hosted in https://www.accuwebhosting.com/vps-hosting/windows-vps-hosting/vps-cloud

    Thanks

    Saturday, September 10, 2016 6:03 AM
  • User-460007017 posted

    Hi sierratec,

    It seems that the problem comes from the error code"0x80070102"

    You could try the following steps:

    1.Go to

     %windir%\system32\inetsrv\fcgiext.ini 


    and locate the ActivityTimeout parameter; copy it into the [php] section. Change the parameter to whatever value you would like, and also make sure that it is not commented out. Restart IIS and you should be good.

    2.configure the activity timeout under server/IIS/FastCGI Settings/Edit in IIS Manager.

    Best Regards,

    Yuk Ding

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Tuesday, September 13, 2016 9:12 AM
  • User-529253680 posted

    Hi Yuk

    Thanks for you reply and sorry for the late reply.

    We checked and could not able to find fast cgi setting

    Also could not able to find fciext.ini

    Kindly suggest

    Monday, September 26, 2016 10:30 AM
  • User-460007017 posted

    Hi sierratec,

    The screenshot you posted only show the feature in website node. It seems that you have installed the CGI feature. You could find the Fast-cgi feature in server node in IIS manager.

    Apologize for my understanding that fciext.ini doesn't exist in IIS 7 and above. You just need to set activityTimeout parameter in Fast-cgi->add application.

    It will be appreciated if you could mark me as the answer.

    Best Regards,

    Yuk Ding

    Monday, September 26, 2016 5:53 PM
  • User-529253680 posted

    Hi Yuk,

    We checked and noted that this was already set. Please refer the below screen shot and suggest if anything additionally needs to be set

    Thanks

    Tuesday, September 27, 2016 5:27 AM
  • User1278090636 posted

    Hi sierratec,

    When you set the Max Instances to 0, it means that it can run as many FastCGI instance as possible.

    You can set it to a specific value to limit the numbers of the FastCGI instances.

    Best Regards,

    Jean

     

    Friday, September 30, 2016 8:31 AM