none
Visual Studio list of open windows is stored where?

    Question

  • VS2015 u3 does not reopen document windows that were open at the time a solution was previously closed. I am pretty sure this is not a problem with VS itself, but with the Intel Fortran compiler and its integration into VS.

    My question is, where does VS store the list of open windows when a solution is closed? Is this information in a file, or the registry, or elsewhere?

    Friday, March 03, 2017 9:33 PM

Answers

  • Hi my friend,

    Refer to your description, it looks like I found the reason, please go to Tools-Options..-Environment-Tabs and Windows, there is an option 'Show auto-hidden windows on mouse over' like the following screenshot. The option is not checked default, you can try to check it and save, then test it on your VS 2015 again.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, March 16, 2017 7:35 AM
    Moderator

All replies

  • VS stores the list of open windows in a .suo file. In VS 2015 this file is stored in a hidden .vs directory along the solution file (.vs\solution_name\v14\.suo). You can try to delete this file in case it is corrupted.

    Sergey Vlasov | Vlasov Studio | Visual Studio add-ins, extensions and tools

    Saturday, March 04, 2017 3:19 AM
  • @Sergey: Thanks for the quick response. I tried deleting the .suo file for one solution, but it had no effect on my problem, so I guess I will have to look elsewhere.

    Is there a VS setting to enable/disable re-opening documents from the previous session?

    Saturday, March 04, 2017 6:57 PM
  • Hi my friend,

    Welcome to the MSDN forum.

    >> VS2015 u3 does not reopen document windows that were open at the time a solution was previously closed.

    Do you mean open the project in VS 2015 and open some files under this project that display in Text Editor windows as tab, then close the project. Open this project again and those files not auto open in Text Editor Windows like the following screenshot:

    If so, I tested this behavior in my VS 2015 and VS 2013 and reopen the project by directly click the xx.sln or in VS, File-Open-Project/Solution and choose the xx.sln file, or Start Page-Recent and directly select one solution, those files auto open with the project like the above shared screenshot.

    You can try to reset the VS setting to check if the default behavior is being affected or not. Go to Tools-Import and Export Settings, click ‘Reset all settings’ and save your current setting, then reset to the default setting, after that, restart the VS to test this issue again.

    If I misunderstand your issue, please correct me and provide the detail steps to reproduce your issue, I will try it on my side again, thank you for your support.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, March 06, 2017 8:04 AM
    Moderator
  • Resetting all settings to the C++ defaults did fix the problem. But now, how can I restore the settings I want, without losing the "restore open documents" ability?
    Thursday, March 09, 2017 8:09 PM
  • Hi my friend,

    Thank you for your feedback.

    It sounds some custom setting affect the default behavior and caused your issue, if you directly import the setting that you saved before reset settings, this issue should be back, you can have a try with this to confirm.

    Does this issue happens to all project types or just C++ projects? We need to troubleshot and find the specific setting that lead to this issue.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, March 10, 2017 3:27 AM
    Moderator
  • Although resetting the settings made the document re-open work, it caused some new issues:

    1) Auto-hide for Solution Explorer and Resource View does not work. Mouse-over does not cause the corresponding windows to appear.

    2) The characteristics of some windows, such as Output, are not retained.

    This happens with a mixed C++/Fortran project, which leads me to believe that the Intel Fortran IDE integration for VS2015 is overwriting part of the .suo file.

    I also just installed VS 2017, and it shows the same symptom (1), but not (2). The VS2017 does not have any Fortran integration.

    Friday, March 10, 2017 3:47 AM
  • Hi my friend,

    >>1) Auto-hide for Solution Explorer and Resource View does not work. Mouse-over does not cause the corresponding windows to appear.

    When we click the 'Auto Hide' icon at the top corner of Solution Explorer, it will display at the right side of VS windows, move mouse on those tabs cannot make it appear, you need to click it. The expected behavior that you describe, mouse move on it to make it appear, as far as I know it is the behavior in VS 2010 version.

    Please go to Control Panel--Programs and Features, right click the VS 2015 item, Change-Repair to repair the VS 2015, in case it is broken or corrupted.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, March 13, 2017 8:36 AM
    Moderator
  • @Sara: Auto-hide works as I described in both VS2013 and VS2015 (installed on a different system). Mousing over the tab makes the corresponding window appear for Solution Explorer.
    Monday, March 13, 2017 9:07 PM
  • Hi my friend,

    Thank you for your confirmation.

    >>Mousing over the tab makes the corresponding window appear for Solution Explorer.

    It looks strange, could you please provide the detail step to reproduce this issue, in case I made misunderstand about your description, I will check it again on my side, thank you for your support. If you can share the screenshot in here, it would be better :)

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, March 14, 2017 9:10 AM
    Moderator
  • To reproduce the issue:

    1) Open a C++ solution or project. Solution Explorer has been set to Auto-Hide.

    2) Mouse over the tab Solution Explorer.

    Nothing happens in VS2015 or VS2017, as installed on system A (except see below). On VS2015 installed on system B, the Solution Explorer window appears. On VS2013 installed on system C, the Solution Explorer window appears.

    ADDED: The Solution Explorer tab is vertical, at the left of the main window. To the right of the tab is a gray bar, about 1.5 mm wide and 2 cm high. This bar "lights up" when the mouse is over the Solution Explorer tab, but the Solution Explorer window does not open, as it should when Auto-Hide is enabled.


    Tuesday, March 14, 2017 6:15 PM
  • Repairing VS2015 did not change the behavior; Auto-Hide still does not work.
    Thursday, March 16, 2017 5:51 AM
  • Hi my friend,

    Refer to your description, it looks like I found the reason, please go to Tools-Options..-Environment-Tabs and Windows, there is an option 'Show auto-hidden windows on mouse over' like the following screenshot. The option is not checked default, you can try to check it and save, then test it on your VS 2015 again.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, March 16, 2017 7:35 AM
    Moderator
  • This box was not checked in VS2015 (probably because I reset the settings to defaults). Checking it made the Auto-Hide work as expected for Solution Explorer.

    But, in VS2017, the box was already checked, but Auto-Hide did not work. I unchecked the box, clicked OK, exited, then went back and clicked it, then OK, and now Auto-Hide works.

    So there is a bug in VS2017 in this regard. I believe I imported my settings from VS2015 (before I reset them, and Auto-Hide originally worked in VS2015).

    Thursday, March 16, 2017 4:03 PM