locked
user specfic filter poblem in content query web part RRS feed

  • Question

  • I need to retrieve user specific records by using content query web part. I have given filter as modified By= xx, xxxxxx [in the people picker field] and clicked on ok button.

    After that I have selected “modify shared web part” to check the condition again. Now in the people picker it is showing as “xx ; xxxxxx” with the error message [You are only allowed to enter one item] below it.(share point treating same name as 2 names)

    Any ideas how to filter the records based on specific user name ??

     

    Thanks in advance...

    Wednesday, September 21, 2011 12:20 PM

Answers

  • Hi Prashanth,

    I reproduced the issue, the display name was devided to 2 names from comma, when clicking "Modify shared web part"after the first time.

    You can post a feedback to the SharePoint product team via this link,http://connect.microsoft.com/site428

    As a workaround, you can correct the name again manually each time when "Modify shared web part", the filter result will still work correctlly as before.

    Thanks

     


    Regards, Daniel
    Friday, September 23, 2011 8:08 AM
    Moderator

All replies

  • Hi Prashanth,

     

    Did you mean the “xx , xxxxxx” was one whole string display in your AD “Display name” property for one user?

    Did the “xx , xxxxxx” also display in your “Welcom” control beside “My Site” link?

     

    You can create another new Content Query web part, click the “Check Name” icon or “browser” icon in people picker field, if the name verified with underline, then click OK button, check the result.

     

    Thanks


    Regards, Daniel
    Friday, September 23, 2011 3:43 AM
    Moderator
  • Thanks for ur replay,

    yes ,  it is the display name property of the user.

    i tried by taking new content web part also, for the first time it is verified by underline. when I am doing "Modify shared web part" the name is displayed as  “xx ; xxxxxx”.

    Friday, September 23, 2011 6:21 AM
  • Hi Prashanth,

    I reproduced the issue, the display name was devided to 2 names from comma, when clicking "Modify shared web part"after the first time.

    You can post a feedback to the SharePoint product team via this link,http://connect.microsoft.com/site428

    As a workaround, you can correct the name again manually each time when "Modify shared web part", the filter result will still work correctlly as before.

    Thanks

     


    Regards, Daniel
    Friday, September 23, 2011 8:08 AM
    Moderator