locked
[Python][Azure Storage] Python error upload data to blob RRS feed

  • Question

  • Hello, I'm having an issue when I run my Python script to upload a file to blob on my azure account. The following error occurs:

    Traceback (most recent call last):
    File "C:\Python27\blobUpload.py", line 1
    from azure.storage.blob import BlobService
    ImportError: No module named azure.storage.blob

    I've installed the azure-storage package using pip install azure-storage. Also, im using Python 2.7. Any help on this would be greatly appreciated. Also it might be worth noting I've tried the same procedure on my Arduino Yun and receive the same error. 

    Thanks.



    Wednesday, June 22, 2016 9:18 PM

Answers

  • Was this the first time you installed these packages at this location? Could you check your python lib folder for additional azure packages?

    Try to pip uninstall those and rerun pip install azure-storage.


    Please mark answered question as anwered to let others know about it.

    Wednesday, June 22, 2016 9:43 PM