locked
Crystal Report does not display after deployment RRS feed

  • Question

  • User-782651317 posted

    Hello everyone,

    I don't know whether this is the right forum to ask this question or not but I really want to get the solution of this problem as it is bugging me for quite some time now.

    The problem is that when I'm developing locally on my machine, eveything works fine. I build a tree of all the .RPT files placed at a specific location on some logic and when I click the node of the tree the specific .RPT file is displayed in CrystalReportViewer control. However, when I follow the same steps after deploying my application on server, nothing is displayed!

    I have 64-bit Windows 7 whereas the server is running Windows Server 2008 with IIS 7.

    Any help in this regard will be highly appreciated.

    Sunday, September 18, 2011 4:23 AM

Answers

  • User1196771204 posted

    hi astahir,

    There are several requirements to run Crystal Report:

    1. Please make sure the CR version installed on the server matches the one you use on your application/website
    2. Please make sure that the assemblies of the CR installed on the server are referenced correctly on your web.config
    3. Please make sure you set the application pool of your application to operate under LOCAL SERVICE permission
    4. Please make sure FULL TRUST mode is enabled on your operating folder
    5. Please make sure crystalreportviewer and aspnet_client folders are copied to your operating folder.

    I have been using Crystal Report for a while. I have also tried the latest Crystal Report for VS 2010 and initially, I experienced the problem like you do now. By following all the steps above, your CR will certainly work fine. Should you still have problems, you can consider hosting it with asphostcentral.com

    Please mark this response as an "answer" if it helps you. Thanks heaps! 

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, September 19, 2011 10:47 PM

All replies

  • User1196771204 posted

    hi astahir,

    do you have full access to the server? If you do, would you please check the crystal report version installed on the server?

    If you don't, you have to contact your current host to check it for you. Please keep me posted. 

    Monday, September 19, 2011 12:40 AM
  • User-782651317 posted

    The following are installed in server:

    • SAP Crystal Reports, version for Visual Studio 2010
    • SAP Crystal Reports runtime engine for .Net Framework 4.0 (32-bits)

    On my local machine, I have:

    • SAP Crystal Reports, version for Visual Studio 2010

    I beleive both machines have CRViewer13

    Monday, September 19, 2011 3:47 AM
  • User1196771204 posted

    astahir,

    do you have full root access to the server? Would you please copy the exact error message here? 

    Monday, September 19, 2011 3:50 AM
  • User-782651317 posted

    Yes I have full access to the server and there is no error! The CrystalReportViewer in which the report is to be loaded simply does not appear.

    Monday, September 19, 2011 4:11 AM
  • User1196771204 posted

    hi astahir,

    There are several requirements to run Crystal Report:

    1. Please make sure the CR version installed on the server matches the one you use on your application/website
    2. Please make sure that the assemblies of the CR installed on the server are referenced correctly on your web.config
    3. Please make sure you set the application pool of your application to operate under LOCAL SERVICE permission
    4. Please make sure FULL TRUST mode is enabled on your operating folder
    5. Please make sure crystalreportviewer and aspnet_client folders are copied to your operating folder.

    I have been using Crystal Report for a while. I have also tried the latest Crystal Report for VS 2010 and initially, I experienced the problem like you do now. By following all the steps above, your CR will certainly work fine. Should you still have problems, you can consider hosting it with asphostcentral.com

    Please mark this response as an "answer" if it helps you. Thanks heaps! 

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, September 19, 2011 10:47 PM
  • User-782651317 posted

    Thanks necro_mancer! I was missing Point No. 5 - now it's working fine :)

    Sunday, September 25, 2011 4:42 AM
  • User1196771204 posted

    hi astahir,

    I am glad to understand that I can help you out :-) 

    Sunday, September 25, 2011 11:31 PM
  • User-782651317 posted

    The pleasure was all mine :)

    By the way, I am facing another problem. Please go to the following link for detail:

    Click here

    Can you shed some light on this?

    Tuesday, September 27, 2011 2:27 AM