locked
MediaElement doesn't work in RTM N

    Question

  • I'm using MediaElement to audio/video playback and in RTM i get NotImplementedException when trying to set SetSource. Looks like MediaElement doesn't exists in N version ?
    Friday, August 17, 2012 11:52 PM

Answers

  • I've added a code to open web page with Media Feature Pack when NotImplementedException is thrown:

    try
    {
      mElement->SetSource(strm, file->ContentType);
    }catch(NotImplementedException^ e)
    {
      auto uri = ref new Uri("http://www.microsoft.com/en-us/download/details.aspx?id=30685");
      Windows::System::Launcher::LaunchUriAsync(uri);
    }
    

    Sunday, August 19, 2012 1:58 PM

All replies

  • Hello Petr,

    This behavior is by design. The Media Foundation core components are not installed with the N version of the operating system.

    Thanks,

    James


    Windows Media SDK Technologies - Microsoft Developer Services - http://blogs.msdn.com/mediasdkstuff/

    Saturday, August 18, 2012 12:15 AM
    Moderator
  • I've installed your Music app from store and it doesn't work (not playing). It is by design as well?
    Saturday, August 18, 2012 8:01 AM
  • This behavior is by design. The Media Foundation core components are not installed with the N version of the operating system.

    Is it Windows 8 Enterprise RTM N edition? I guess Enterprise edition should have included all components. What is the solution when an enterprise need to use media?

    Charlie Chang L

    Saturday, August 18, 2012 2:25 PM
  • I've added a code to open web page with Media Feature Pack when NotImplementedException is thrown:

    try
    {
      mElement->SetSource(strm, file->ContentType);
    }catch(NotImplementedException^ e)
    {
      auto uri = ref new Uri("http://www.microsoft.com/en-us/download/details.aspx?id=30685");
      Windows::System::Launcher::LaunchUriAsync(uri);
    }
    

    Sunday, August 19, 2012 1:58 PM