locked
wap pages using VS.NET RRS feed

  • Question

  • User137888575 posted
    Hi, i am trying to create a WAP page using asp.net. i am writing the code using VS.NET I installed Mictosoft Internet Tool kit and i start with "Imports System.Web.mobile" but it is giving an error as follows "Namespace or type 'mobile' for the Imports 'System.Web.mobile' cannot be found." how can i set up my VS.NET to develop a wap page? ThanQ
    Wednesday, November 3, 2004 3:52 AM

All replies

  • User519798937 posted
    u should create mobile application
    Thursday, November 4, 2004 10:16 PM
  • User-307753031 posted
    I'm troubleshooting a similar problem. My error message is: namespace or type 'mail' for the imports 'System.Web.Mail' cannot be found. I suspect this is due to the fact that I installed SMTP server to IIS after installing the .NET framework. This may simply be an IIS registration problem. Possible solutions I'm investigating: - will execution of aspnet_regiis.exe -i fix the problem? - will running the VS.Studio setup and selecting "Repair" take care of it? - do I need to unregister .NET from IIS and re-register it? Hope this helps. Randy Daddis
    Thursday, November 4, 2004 11:15 PM
  • User-307753031 posted
    Followup - - aspnet_regiis.exe -i did not work -VS.Studio setup repair prerequisites did not work - VS.Studio repair did not work - uninstalled and reinstalled .NET framework did not work My implementation of .NET framework version 1.1.4322 seems to be missing the System.Web.Mail namespace. I assume this to be System.Web.Mail.dll - I cannot find System.Web.Mail.dll on my hard drive. The next thing I can think of is to uninstall VS.Studio and .NET framework and then reinstall. Any suggestions? Thanks, Randy Daddis
    Friday, November 5, 2004 2:17 AM
  • User-307753031 posted
    My problem seems to have been a .NET framework :(newbie:( issue. I assumed there would be a System.Web.Mail assembly that would show up in the Add Reference | .NET Component list. After examining System.Web.dll with ***WinCV.exe*** and ***ildasm.exe***, it became apparent to me that System.Web.Mail is a namespace within the System.Web assembly. I needed to add a reference to System.Web, not System.Web.Mail. My lesson from this seems to be that only global assemblies appear in Add Reference | .NET Component list. I would appreciate confirmation of this:) ----------------------------------------------------------------------------------------------------- Now back to your error message of "Namespace or type 'mobile' for the Imports 'System.Web.mobile' cannot be found." System.Web.mobile.dll exists in my global assembly (gac) & I haven't installed the Microsoft Internet Tool kit. I assume that it should be in your gac also. To view the contents of your gac: Using Windows Explorer, navigate to <System Drive>:\<Windows Folder>\assembly. My understanding is that all of your global assemblie are stored here. Hope this helps. Randy Daddis
    Friday, November 5, 2004 4:37 PM