none
Trouble Linking 3rd Party 'dll', 'lib', and 'h' files to Compact 7 Subproject RRS feed

  • Question

  • I posted this issue before but I am going to re-ask it with a little better information.

    I have a windows compact 7 project and it has a subproject. This is being built in visual studio 2008.

    I have some 3rd party functionality for CNC machines that I require a dll file for. The files are "Fwlib32".dll/.lib and .h

    I have created an application in Visual Studio 2012 in Visual C++ and I can get the required functionality to work.

    When I try to do the same in my subproject in Visual Studio 2008, I get the following errors.

        BUILD: [01:0000000148:ERRORE] Error(s) in directory "C:\WINCE700\OSDesigns\OSDesign1\SilverlightApplication1\SilverlightApp1\".
    
        error LNK2019: unresolved external symbol __imp__cnc_allclibhndl3 referenced in function "public: long __thiscall MainPage::btnRead_Click(class IXRDependencyObject *,struct XRMouseButtonEventArgs *)" (?btnRead_Click@MainPage@@QAEJPAVIXRDependencyObject@@PAUXRMouseButtonEventArgs@@@Z) C:\WINCE700\OSDesigns\OSDesign1\SilverlightApplication1\SilverlightApp1\bldsys.log
    
        BUILD: [01:0000000151:ERRORE] NMAKE : fatal error U1077: 'C:\WINCE700\sdk\bin\i386\x86\link.EXE' : return code '0x460'
    

    I am putting those 3 files in the following location. This is the location of my subproject.

    C:\WINCE700\OSDesigns\OSDesign1\SilverlightApplication1\SilverlightApp1\

    Under the "Link" tab in the sub-project's properties. In the additional library box I have the following...

    fwlib32.lib $(SG_OUTPUT_ROOT)\sdk\lib\$(_CPUINDPATH)\coredll.lib $(SG_OUTPUT_ROOT)\sdk\lib\$(_CPUINDPATH)\xamlruntime.lib

    I have tried using the full path and just the file name, both seem to fail....

    What am I missing!?

    Any ideas or help will be appreciated.


    Monday, June 9, 2014 7:25 PM

All replies

  • It is not able to link to this function "__imp__cnc_allclibhndl3" called in "btnRead_Click" 

    You just need to find which .lib file contains the defination of "imp__cnc_allclibhndl3"

    You are adding the header but lib is missing ...

    If you added the corresponding lib make sure your lib file is linked 

    You can also try building the same lib file using VS2008 separately again and try adding. 

    --- Misbah


    Senior Design Engineer T.E.S Electroni Solutions (Bangalore-India) www.tes-dst.com email-misbah.khan@tes-dst.com


    Tuesday, June 10, 2014 5:40 AM
  • Just to double check, to 'link' a .lib file in this type of project. You go to the sub-project's properties and go under the link tab and add it to the additional libraries box?

    How does one go about rebuilding a lib file? I got all 3 of these files off the web and they worked in my standalone test application in vs2012

    Tuesday, June 10, 2014 3:20 PM