locked
HTTP Error 500.0 - Internal Server Error RRS feed

  • Question

  • User423106978 posted

    Hi ,

    When i am pushing the message into webservice i am getting following error.

    I given full permissions to virtual directory 

    <div class="content-container">
     <fieldset><legend>Error Summary</legend>
      <h2>HTTP Error 500.0 - Internal Server Error</h2>
      <h3>The page cannot be displayed because an internal server error has occurred.</h3>
     </fieldset>
    </div>
    <div class="content-container">
     <fieldset><legend>Detailed Error Information</legend>
      <div id="details-left">
       <table border="0" cellpadding="0" cellspacing="0">
        <tr class="alt"><th>Module</th><td>IsapiModule</td></tr>
        <tr><th>Notification</th><td>ExecuteRequestHandler</td></tr>
        <tr class="alt"><th>Handler</th><td>ISAPI-dll</td></tr>
        <tr><th>Error Code</th><td>0x800700c1</td></tr>
        
       </table>
      </div>
      <div id="details-right">
       <table border="0" cellpadding="0" cellspacing="0">
        <tr class="alt"><th>Requested URL</th><td>http://omidcm023:80/BizTalk HTTP Receive/BTSHTTPReceive.dll?ResubmitPortName=rcvxmldocport_Http</td></tr>
        <tr><th>Physical Path</th><td>E:\Program Files (x86)\Microsoft BizTalk Server 2010\HttpReceive64\BTSHTTPReceive.dll</td></tr>
        <tr class="alt"><th>Logon Method</th><td>Anonymous</td></tr>
        <tr><th>Logon User</th><td>Anonymous</td></tr>
        <tr class="alt"><th>Failed Request Tracing Log Directory</th><td><a href="file://C:\inetpub\logs\FailedReqLogFiles">C:\inetpub\logs\FailedReqLogFiles</a></td></tr>
       </table>
       <div class="clear"></div>
      </div>
     </fieldset>
    </div>
    <div class="content-container">
     <fieldset><legend>Most likely causes:</legend>
      <ul>     <li>IIS received the request; however, an internal error occurred during the processing of the request. The root cause of this error depends on which module handles the request and what was happening in the worker process when this error occurred.</li>     <li>IIS was not able to access the web.config file for the Web site or application. This can occur if the NTFS permissions are set incorrectly.</li>     <li>IIS was not able to process configuration for the Web site or application.</li>     <li>The authenticated user does not have permission to use this DLL.</li>     <li>The request is mapped to a managed handler but the .NET Extensibility Feature is not installed.</li> </ul>
     </fieldset>
    </div>
    <div class="content-container">
     <fieldset><legend>Things you can try:</legend>
      <ul>     <li>Ensure that the NTFS permissions for the web.config file are correct and allow access to the Web server's machine account.</li>     <li>Check the event logs to see if any additional information was logged.</li>     <li>Verify the permissions for the DLL.</li>     <li>Install the .NET Extensibility feature if the request is mapped to a managed handler.</li>     <li>Create a tracing rule to track failed requests for this HTTP status code. For more information about creating a tracing rule for failed requests, click <a href="http://go.microsoft.com/fwlink/?LinkID=66439">here</a>. </li> </ul>
     </fieldset>
    </div>
     

    Friday, July 20, 2012 11:41 AM

Answers

  • User423106978 posted

    Thanks for your reply and the issue got resolved .

    The issue is  in our biztalk webservice 

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, July 23, 2012 5:36 AM

All replies

  • User212506688 posted

    Hi,

    Check the 32/64 bit requirement plus check if there is a requirement for integrated/Classic mode for you application pool to run in.

     Make sure that your application pool identitiy or the IIS_USRS groups has the right access to the BTSHTTPReceive.dll module.

    This is an error in the execution or the access to the module.

    Also, check the http sub-status code and see if you can search for more details on it.

     HTH, Ben

    Friday, July 20, 2012 12:20 PM
  • User423106978 posted

    Thanks for your reply and the issue got resolved .

    The issue is  in our biztalk webservice 

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, July 23, 2012 5:36 AM