locked
HTML client & Sharepoint 2013 RRS feed

  • Question

  • When I change Sharepoint settings in the project from one Sharepoint server to another, I always get the message 

    Value cannot be null.
    Parameter name: sharePointHostData

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.ArgumentNullException: Value cannot be null.
    Parameter name: sharePointHostData

    Source Error:
    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:
    [ArgumentNullException: Value cannot be null.
    Parameter name: sharePointHostData]
       Microsoft.LightSwitch.Framework.Server.SharePointHost..ctor(SharePointAuthDataBase sharePointHostData) +97
       Microsoft.LightSwitch.Framework.Server.SharePointApplication`3.get_SharePoint() +85
       Microsoft.LightSwitch.Framework.Server.SharePointLaunchBase.Page_Load(Object sender, EventArgs e) +162
       System.Web.UI.Control.OnLoad(EventArgs e) +92
       System.Web.UI.Control.LoadRecursive() +54
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +772

    when I start solution with F5 from Visual studio. Can anyone have an idea why?
    Connecting to dev site directly on that sharepoint server is fine, but when I want to use it for debug....error.

    Thanks!

    Wednesday, November 12, 2014 2:37 PM

Answers

All replies

  • To troubleshoot this issue, you need follow the blog above to configure your SharePoint first.

    Moreover, here are some suggestions for you.

    1. To create an app for SharePoint, you enable the SharePoint features in LightSwitch. 

    Reference: Enable an application for SharePoint

    2. Deploy A LightSwitch Application To Office 365 / SharePoint Online

    • Marked as answer by Angie Xu Tuesday, November 25, 2014 1:49 AM
    Thursday, November 13, 2014 2:55 AM
  • Having the exact same problem. Have read all the blogs, and have tried everything. Has anyone gotten this to work?

    Stephen

    Tuesday, December 30, 2014 3:58 AM
  • Please check this out...

    http://cesarloaiza.blogspot.com/2015/06/sharepoint-lightswitch-app-and-on.html

    Wednesday, July 1, 2015 3:29 PM
  • I was struggeling with the same problem. Two diffrent things coursed this in my case:

    1. Wrong Password given for the high-trust certificate

    2. A incompleted connection string in Web.Config connectionStrings node

    <addname="7ad2819b-122f-4e8e-9046-199fe235f881"connectionString=""/>

    deleting this node solved the problem for me.

     
    Monday, July 6, 2015 5:01 PM