none
[Old Portal] Storage Account is not listed

    Question

  • I'm trying to configure custom domain name for my storage account created using the new portal. At present. this configuration is available only through the old portal.

    When I open the old portal, the storage account is not listed. Kindly help.

    Sunday, February 14, 2016 2:18 PM

Answers

  • Hello,

    I am afraid I am not aware of the timeline for the functionality to be added. The PowerShell is very straightforward, you just need to run the following, substituting your storage and domain details:

    Install-Module AzureRM #only needed if not already installed
    Login-AzureRMAccount
    Set-AzureRmStorageAccount -ResourceGroupName "MyResourceGroup" -AccountName "mystorageaccount" -CustomDomainName "www.domainname.com" -UseSubDomain $True
    

    PowerShell knowledge is a vital skill when working with Azure and would encourage you to take time to skil up!

    Hope that helps,

    Marcus

    Monday, February 15, 2016 7:05 PM
    Moderator

All replies

  • Hello,

    There are two deployment models for Azure "classic/service" manage and "resource manager". I suspect you have created the storage account using resource manager. Resource manager resources are only available via the new portal. Classic/Service Manager resources are available in both.

    As you state the ability to add the custom domain isn't available in the new portal, you have the following options:
    1. Add the custom domain using PowerShell, see https://msdn.microsoft.com/en-us/library/mt607146.aspx, Example 2:

    Set-AzureRmStorageAccount -ResourceGroupName "MyResourceGroup" -AccountName "mystorageaccount" -CustomDomainName "www.domainname.com" -UseSubDomain $True
    

    2. Recreate the storage account as a classic storage account and configure in the old profile.

    Option 1 would be the best way to progress given Resource Manager should now be used whenever possible.

    I hope that resolves your issue,

    Marcus

    Monday, February 15, 2016 12:07 AM
    Moderator
  • As Marcus just said.

    If you created a resources (VM, Storage, etc...) in the new portal in Resource mode in the new portal you will not be able to see your resource in the "Old Portal"...

    If you want to do so, you have to be sure to choose "Classic" mode a the bottom of the creation blade form the new portal.

    Hope it help

    Julien

    Monday, February 15, 2016 2:12 AM
  • Thank you. When can i expect the UI for this configuration because verifying domain using PowerShell might be difficult i believe?
    Monday, February 15, 2016 6:52 PM
  • Hello,

    I am afraid I am not aware of the timeline for the functionality to be added. The PowerShell is very straightforward, you just need to run the following, substituting your storage and domain details:

    Install-Module AzureRM #only needed if not already installed
    Login-AzureRMAccount
    Set-AzureRmStorageAccount -ResourceGroupName "MyResourceGroup" -AccountName "mystorageaccount" -CustomDomainName "www.domainname.com" -UseSubDomain $True
    

    PowerShell knowledge is a vital skill when working with Azure and would encourage you to take time to skil up!

    Hope that helps,

    Marcus

    Monday, February 15, 2016 7:05 PM
    Moderator