locked
Visual Studio 2013 asp.net Precompile options missing the "Use IIS metabase path for source input." RRS feed

  • Question

  • User1440293048 posted

    This option is missing from my configuration screen. I have the latest update 4 installked.

    Because I cannot check this box I get a theme not found error when I attempt to publish a project referencing a global theme that is not in the applicaiton virtual directory.

    Anyone know of a workaround?

    Friday, January 16, 2015 1:00 PM

Answers

  • User-166373564 posted

    Hi tsvsega,

    You can try the workaround below, and check whether it can fix this issue. Update a couple lines in your publish profile xml file (App_Data\PublishProfiles\).  Add these lines:

    <UseMetabasePath>True</UseMetabasePath>  

    <SourceWebMetabasePath>/LM/W3SVC/1/ROOT/{THE PATH TO YOUR WEB SITE IN ISS}</SourceWebMetabasePath>

    Please let me know if there is anything that I can do to help.

    Best regards,

    Angie

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, January 27, 2015 1:58 AM

All replies

  • User-166373564 posted

    Hi tsvsega,

    Visual Studio 2013 asp.net Precompile options missing the "Use IIS metabase path for source input...

    For this issue, it's recommended to repair our VS2013 first, and check whether it helps to fix it.

    To repair Visual Studio

    1.In Control Panel, on the Programs and Features page, choose the product edition that you want to repair, and then choose Uninstall/Change.

    2.In the Setup wizard, choose Repair, choose Next, and then follow the remaining instructions.

    Please let me know if there is anything that I can do to help.

    Best regards,

    Angie

    Monday, January 19, 2015 1:18 AM
  • User1440293048 posted

    Reinstallation does NOT fix it.

    Was this option removed for 2013?

    when a global theme is used in website it compiles fine if you just do a build

    in visual studio bit gives theme not found

    error when you try to publish with precomoile option set.

    Putting theme local in project fixes the error

    but that defeats the point of global themes.

    Monday, January 19, 2015 8:21 PM
  • User-166373564 posted

    Hi tsvsega,

    You can try the workaround below, and check whether it can fix this issue. Update a couple lines in your publish profile xml file (App_Data\PublishProfiles\).  Add these lines:

    <UseMetabasePath>True</UseMetabasePath>  

    <SourceWebMetabasePath>/LM/W3SVC/1/ROOT/{THE PATH TO YOUR WEB SITE IN ISS}</SourceWebMetabasePath>

    Please let me know if there is anything that I can do to help.

    Best regards,

    Angie

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, January 27, 2015 1:58 AM