locked
How do I turn off feature testing in the Test Explorer window RRS feed

  • Question

  • User-1080297099 posted

    I run Unit Tests categorized by Class in the TEST Explorer window.
    Others on my team have written Feature Tests or automated integration Tests.

    In Visual Studio 2013 the integration tests did not show up for me in the Test Explorer window which is fine with me because I am not involved in that.
    I just want to be able to run my integration tests quickly.
    But the feature tests take a long time.

    Now in VS 2015, the feature tests are showing up for me.
    Is there a setting to have these not show up in the Test Explorer window?  And basically not be discovered?

    Also, if I go to Tools -> Options, I expect to see a "Test Tools" option.  But its not there.

    Monday, April 18, 2016 2:56 PM

Answers

  • User-166373564 posted

    Hi,

    I don't understand why it was just set up like this for me by default in Visual Studio 2013 until we switched to VS 2015.
    Now I see them all.

    Please try start Visual Studio in safe mode, loading only the default environment and services, and check whether it can fix it.

    Regards,

    Angie

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, April 28, 2016 3:04 AM

All replies

  • User-166373564 posted

    Hi,

    Generally I use the following way to disable unit test:

    Select the test in the Test List Editor or the Test View window and press F4 to display the Properties window. Then, set the value of the Test Enabled property to False.

    Have a good day.

    Regards,

    Angie

    Tuesday, April 19, 2016 9:06 AM
  • User-1080297099 posted

    Thanks,  I selected the test, but nothing shows up for it in the properties window.

    It is just empty.

    Also I need a way to turn off all the feature tests.  Not one by one.
    I don't understand why it was just set up like this for me by default in Visual Studio 2013 until we switched to VS 2015.
    Now I see them all.

    Also wondering why there are no Test options in "Tools -> Options".

    Tuesday, April 19, 2016 1:04 PM
  • User-166373564 posted

    Hi,

    I don't understand why it was just set up like this for me by default in Visual Studio 2013 until we switched to VS 2015.
    Now I see them all.

    Please try start Visual Studio in safe mode, loading only the default environment and services, and check whether it can fix it.

    Regards,

    Angie

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, April 28, 2016 3:04 AM