locked
Azure SDK 2.3 - can't deploy RRS feed

  • Question

  • I just upgraded to SDK 2.3. I'm using VS 2012. I can no longer deploy my project, either directly or by packaging first. HELP! Below is the error I get. It appears to be related to web deploy, but I am certain web deploy 3.5 is loaded....I did it twice.  Any ideas?

    Error 1 The "ImportParametersFile" task failed unexpectedly.
    System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.Web.XmlTransform, Version=1.4.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.
    File name: 'Microsoft.Web.XmlTransform, Version=1.4.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'
    at Microsoft.Web.Publishing.Tasks.ImportParametersFile.Execute()
    at Microsoft.Build.BackEnd.TaskExecutionHost.Microsoft.Build.BackEnd.ITaskExecutionHost.Execute()
    at Microsoft.Build.BackEnd.TaskBuilder.<ExecuteInstantiatedTask>d__20.MoveNext()

    Tuesday, April 8, 2014 1:34 AM

Answers

  • Hi,

    I suggest you  remove all your azure SDK, after that, reinstall Azure SDK 2.3 according to the following article.

    #http://azure.microsoft.com/en-us/downloads/archive-net-downloads/

    Hope this helps, if not, please feel free to let me know.

    Best Regards


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, April 8, 2014 7:07 AM

All replies

  • Hi,

    I suggest you  remove all your azure SDK, after that, reinstall Azure SDK 2.3 according to the following article.

    #http://azure.microsoft.com/en-us/downloads/archive-net-downloads/

    Hope this helps, if not, please feel free to let me know.

    Best Regards


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, April 8, 2014 7:07 AM
  • Hi, 

    I had the same issue and after reinstalling (repair) VS 2012 the problem was solved. Webtools 2013.1 package is the one that installs Microsoft.Web.XmlTransform  in your computer, and the dll should be located on "C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v11.0\Web" folder.


    • Edited by A.Agirre Wednesday, April 9, 2014 10:06 AM
    Tuesday, April 8, 2014 8:48 PM
  • Hi, 

    I as well have this issue and I tried to remove azure SDK as well trying to (repair) VS2012 but without result. Do you have any suggestion how to solve this issue?

    Friday, April 11, 2014 9:00 AM
  • Same here, I've uninstalled azure SDK and Visual Studio then Reinstalled Visual Studio...and it's still broken.

    Update:

    Ok repairing directly "Microsoft ASP.NET and Web Tools 2013.1 - Visual Studio 2012" did the trick for me.

    Now I guess you actually don't need to repair the whole Visual Studio 2012 install but just this component.



    • Edited by sigomatix Friday, April 11, 2014 3:48 PM
    • Proposed as answer by Erik61 Monday, April 28, 2014 4:53 PM
    Friday, April 11, 2014 3:17 PM
  • I managed to fix it only by taking that DLL (Microsoft.Web.XmlTransform.dll) from another computer and copying it into the directory A.Agirre mentioned in one of the previous posts.

    I've tried both: re-installing Azure SDK and repairing Visual Studio 2012. Without any success.


    Best regards, Sergiy Korzh
    EasyQuery - user-friendly search control for your application or web-site.
    AppLocalizer - Localization tool-kit for Visual Studio projects.


    Thursday, April 17, 2014 4:46 AM
  • Yes, you are right. I only repaired "Microsoft ASP.NET and Web Tools 2013.1 - Visual Studio 2012" and the problem is gone. Thank you!
    Thursday, May 1, 2014 5:49 PM
  • Repairing Microsoft ASP.NET and Web Tools 2013.1 - Visual Studio 2012 did not help me. So, I un-installed it and reinstalled the AspNetWebTools2013_1Setup.exe and WebToolsExtensionsVS.MSI from the below URL. The web folder was created only when I ran the WebToolsExtensionsVS.MSI.

    http://www.microsoft.com/en-us/download/details.aspx?id=41532


    • Edited by SelvaPS Saturday, May 3, 2014 4:41 AM
    Saturday, May 3, 2014 4:39 AM
  • The trick of copy the DLL works for me too!! 

    The following DLL from another PC with VS2012 installed:
    **Microsoft.Web.XmlTransforms.dll**  

    from:  **C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v11.0\Web**  

    Thursday, May 8, 2014 2:22 PM