locked
Problem with LogonAPI (advapi32.dll) RRS feed

  • Question

  • User2004373635 posted
    Hi All, I have developed an asp.net application in that I have logon screen for the users, for that I am using LogonAPI to validate windows users. In the development machine it works fine, it validate the users correctly with the domain (it returns true if correct user name & password are entered), but after I install to server it always return false (i.e it always return invalid user). Can anyone help me to find the problem. Thanks in advance.
    Sunday, August 3, 2003 5:02 AM

All replies

  • User76536425 posted
    You might want to post the code you're using. As long as you have the same resources on the server it should work, unless there is some kind of permissions thing going on. Don
    Sunday, August 10, 2003 3:48 PM
  • User-2113672972 posted

    I couldn't have developed such a application as I don't  like to spend time solving errors after making such an amazing application. If you do like to fix advapi32.dll missing file error then try below steps this might help you. 

    Replace the missing file or your corrupted file with a new one that will not cause such an issue. Now let us understand how to run this command.

    Step 1: Open command prompt as an administrator.

    Step 2: Type “sfc /scannow”

    sfc/scannow

    Step 3: It should now verify your operating system. Your screen should look like this.

    sfc/scannow

    Step 4: Now you have to wait for your problems to get identified. After the process is over your screen should look like this.

    If problems are found

    Step 5: If you do not have any problems then your screen will look like this.

    If no issues are found

    Friday, February 14, 2020 7:03 AM