none
Bing Maps WPF Control RRS feed

  • Question

  • Hello COMMUNITY

    I'm testing the brand new WPF Control to show a Bing Map on a simple Windows Desktop app, so i started whit a Get started tutorial posted  here (https://msdn.microsoft.com/en-us/library/hh830433.aspx). So i create a map using the "m:Map" tag, run my application and works fine.

    Later i modified the app just like the tutorial above said, adding the Bing Map key, and when i run my app for the second time the maps does not appear anymore.

    I tested the key and works fine, so i create a second app following the same tutorial and the map still showing a GRAY background. i can only see the Bing map logo on the bottom left corner and the scale on the bottom right, i move the map using my mouse scroll and the scale changes but the map just still on gray, it's something related with my internet connection?? why runs well the first time?

    Friday, January 23, 2015 3:16 AM

Answers

All replies

  • To start off with, make sure you have an internet connection. If there is no connection the map won't be able to access the data.

    http://rbrundritt.wordpress.com

    Friday, January 23, 2015 4:07 AM
  • I meet the same problem!

    I find something interesting. 

    1, I build a WPF application, and it shows a GRAY background.

    2, I build a silverlight application without website, and it shows a blank and navigation toolkit.

    3, I build a silverlight application with website, and the bingmap works well.

    What's the problem?

    Friday, January 23, 2015 9:21 AM
  • Hi Ricky!

    Thanks for answer, i tried with two distinct networks and still the same problem! i copied the bin/debug files on another computer and the map works well only the first run, when i reopened the app the map disappeared and show a gray background.

    I tried to run the bin/debug files on a windows server 2008 R2 Enterprise and everything works FINE :)

    I'm using windows 7 on both computers


    Friday, January 23, 2015 2:54 PM
  • What country are you located in? It's possible that you might be in a country in which we currently do not support as documented here: https://msdn.microsoft.com/en-us/library/jj670541.aspx

    When the WPF map control loads it requests a config file from our servers. If you can get a fiddler trace of that config file I can have our engineering team look into this deeper.


    http://rbrundritt.wordpress.com

    Friday, January 23, 2015 4:47 PM
  • With this is enough??

    GET http://dev.virtualearth.net/REST/v1/GeospatialEndpoint/es-ES/ES/?o=xml&key=AnzLvLWGD8KU7wavNObJJdFVQcEGKMuBfBZ08b_Fo2cLb2HANvULeuewDmPDYExL HTTP/1.1
    Host: dev.virtualearth.net
    Proxy-Connection: Keep-Alive


    HTTP/1.0 200 OK
    Cache-Control: no-cache
    Content-Type: application/xml; charset=utf-8
    Server: Microsoft-IIS/8.0
    X-BM-TraceID: 9efc69f4001745cea666d1200da31dc6
    X-BM-Srv: BN20130723
    X-MS-BM-WS-INFO: 0
    X-AspNet-Version: 4.0.30319
    X-Powered-By: ASP.NET
    X-Powered-By: ASP.NET
    Date: Fri, 23 Jan 2015 20:31:16 GMT
    Content-Length: 5185
    X-Cache: MISS from sr_proxy.dj.cfemex.com
    X-Cache-Lookup: MISS from sr_proxy.dj.cfemex.com:80
    Via: 1.0 sr_proxy.dj.cfemex.com (squid/3.1.10)
    Connection: keep-alive

    <?xml version="1.0" encoding="utf-8"?><Response xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://schemas.microsoft.com/search/local/ws/rest/v1"><Copyright>Copyright © 2015 Microsoft and its suppliers. All rights reserved. This API cannot be accessed and the content and any results may not be used, reproduced or transmitted in any manner without express written permission from Microsoft Corporation.</Copyright><BrandLogoUri>http://dev.virtualearth.net/Branding/logo_powered_by.png</BrandLogoUri><StatusCode>200</StatusCode><StatusDescription>OK</StatusDescription><AuthenticationResultCode>ValidCredentials</AuthenticationResultCode><TraceId>9efc69f4001745cea666d1200da31dc6|BN20130723|02.00.119.2100|</TraceId><ResourceSets><ResourceSet><EstimatedTotal>1</EstimatedTotal><Resources><Resource xsi:type="GeospatialEndpointResponse"><UR>ES</UR><IsDisputedArea>false</IsDisputedArea><IsSupported>true</IsSupported><Services><ServiceInfo><ServiceName>RoadWithLabels</ServiceName><Endpoint>ak.dynamic.t{0-3}.tiles.virtualearth.net/comp/ch/{quadkey}?mkt=es&amp;it=G,L&amp;shading=hill&amp;og=69&amp;n=z</Endpoint><LanguageSupported>false</LanguageSupported><FallbackLanguageId>es</FallbackLanguageId></ServiceInfo><ServiceInfo><ServiceName>AerialWithLabels</ServiceName><Endpoint>ak.dynamic.t{0-3}.tiles.virtualearth.net/comp/ch/{quadkey}?mkt=es&amp;it=A,G,L&amp;og=69&amp;n=z</Endpoint><LanguageSupported>false</LanguageSupported><FallbackLanguageId>es</FallbackLanguageId></ServiceInfo><ServiceInfo><ServiceName>RoadWithoutLabels</ServiceName><Endpoint>ak.dynamic.t{0-3}.tiles.virtualearth.net/comp/ch/{quadkey}?mkt=es&amp;it=G&amp;shading=hill&amp;og=69&amp;n=z</Endpoint><LanguageSupported>false</LanguageSupported><FallbackLanguageId>es</FallbackLanguageId></ServiceInfo><ServiceInfo><ServiceName>AerialWithoutLabels</ServiceName><Endpoint>ecn.t{0-3}.tiles.virtualearth.net/tiles/a{quadkey}.jpeg?g=3218</Endpoint><LanguageSupported>false</LanguageSupported><FallbackLanguageId>es</FallbackLanguageId></ServiceInfo><ServiceInfo><ServiceName>MapTiles</ServiceName><Endpoint>ecn.dynamic.t{0-3}.tiles.virtualearth.net/comp/ch/{quadkey}?mkt=es&amp;it=G,VE,BX,L,LA&amp;shading=hill&amp;og=52&amp;n=z</Endpoint><LanguageSupported>false</LanguageSupported><FallbackLanguageId>es</FallbackLanguageId></ServiceInfo><ServiceInfo><ServiceName>TrafficTiles</ServiceName><Endpoint>t{0-3}-traffic.tiles.virtualearth.net/comp/ch/{quadkey}?it=Z,TF&amp;n=z&amp;key={authKey}</Endpoint><LanguageSupported>false</LanguageSupported><FallbackLanguageId>es</FallbackLanguageId></ServiceInfo><ServiceInfo><ServiceName>StaticMapsB2B</ServiceName><Endpoint>dev.virtualearth.net/REST/V1/Imagery/Map</Endpoint><LanguageSupported>false</LanguageSupported><FallbackLanguageId>es</FallbackLanguageId></ServiceInfo><ServiceInfo><ServiceName>MetadataB2B</ServiceName><Endpoint>dev.virtualearth.net/REST/V1/Imagery/Metadata</Endpoint><LanguageSupported>false</LanguageSupported><FallbackLanguageId>es</FallbackLanguageId></ServiceInfo><ServiceInfo><ServiceName>Geocode</ServiceName><Endpoint>dev.virtualearth.net/REST/v1/Locations</Endpoint><LanguageSupported>false</LanguageSupported><FallbackLanguageId>es</FallbackLanguageId></ServiceInfo><ServiceInfo><ServiceName>Route</ServiceName><Endpoint>dev.virtualearth.net/REST/v1/Routes</Endpoint><LanguageSupported>false</LanguageSupported><FallbackLanguageId>es</FallbackLanguageId></ServiceInfo><ServiceInfo><ServiceName>Copyright</ServiceName><Endpoint>dev.virtualearth.net/REST/V1/Imagery/Copyright/es/{imagerySet}/{zoom}/{minLat}/{minLon}/{maxLat}/{maxLon}?output={outputType}&amp;dir={heading}&amp;key={authKey}</Endpoint><LanguageSupported>false</LanguageSupported><FallbackLanguageId>es</FallbackLanguageId></ServiceInfo><ServiceInfo><ServiceName>WPFLogging</ServiceName><Endpoint>dev.virtualearth.net/webservices/v1/LoggingService/LoggingService.svc/Log?entry={entryPoint}&amp;auth={authKey}&amp;fmt=1&amp;type=3&amp;group=MapControl&amp;name=WPF&amp;version={productBuildVersion}&amp;session={session}&amp;mkt=es</Endpoint><LanguageSupported>false</LanguageSupported><FallbackLanguageId>es</FallbackLanguageId></ServiceInfo><ServiceInfo><ServiceName>BingLogo</ServiceName><Endpoint>ecn.dev.virtualearth.net/Branding/Bing.png</Endpoint><LanguageSupported>false</LanguageSupported><FallbackLanguageId>es</FallbackLanguageId></ServiceInfo><ServiceInfo><ServiceName>CombinedLogo</ServiceName><Endpoint>ecn.dev.virtualearth.net/Branding/Nokia_Bing.png</Endpoint><LanguageSupported>false</LanguageSupported><FallbackLanguageId>es</FallbackLanguageId></ServiceInfo><ServiceInfo><ServiceName>BingLogoAerial</ServiceName><Endpoint>ecn.dev.virtualearth.net/Branding/Bing_aerial.png</Endpoint><LanguageSupported>false</LanguageSupported><FallbackLanguageId>es</FallbackLanguageId></ServiceInfo><ServiceInfo><ServiceName>CombinedLogoAerial</ServiceName><Endpoint>ecn.dev.virtualearth.net/Branding/Nokia_Bing_aerial.png</Endpoint><LanguageSupported>false</LanguageSupported><FallbackLanguageId>es</FallbackLanguageId></ServiceInfo></Services></Resource></Resources></ResourceSet></ResourceSets></Response>

    Friday, January 23, 2015 8:35 PM
  • This is exactly what our developers was looking for. I believe they already spotted the issue and seeing what's involved to correct it.

    http://rbrundritt.wordpress.com

    Friday, January 23, 2015 8:52 PM
  • I forgot to tell that i'm locate at México
    Friday, January 23, 2015 8:53 PM
  • I really appreciate your quick and assertive response, I can not wait to continue my project and take advantage of this wonderful technology .

    Thanks for everything

    Friday, January 23, 2015 9:39 PM
  • Hi Ricky_Brundritt, any notice??
    Tuesday, January 27, 2015 1:01 AM
  • The team has identified the issue and is working on creating an update. Note that before an update can be released there is a few additional things our developers have to do such as getting the libraries digitally signed with a Microsoft certificate and a few other red-tape things released to releases at Microsoft. Once these are sorted out they will release an update. I'll update this thread when this is done.

    http://rbrundritt.wordpress.com

    Tuesday, January 27, 2015 2:02 AM
  •  public partial class MainWindow : Window
        {
            public MainWindow()
            {
                Thread.CurrentThread.CurrentUICulture = new CultureInfo("en-US");
                InitializeComponent();
            }
        }

    This is a quick solution.

    We waiting for update...

    • Proposed as answer by graisoft1982 Sunday, February 1, 2015 1:45 PM
    • Edited by graisoft1982 Sunday, February 1, 2015 1:46 PM
    • Marked as answer by Victor Stivalet Tuesday, February 3, 2015 3:57 PM
    Sunday, February 1, 2015 1:45 PM
  • Perfect, it works! Thanks Granoviter
    Tuesday, February 3, 2015 3:57 PM
  • it works... but only if i use "en_US" cultureinfo....

    is any other language supported?

    thanks

    Tuesday, February 10, 2015 9:10 PM
  • Part of the current bug that the team is fixing is how the WPF map control handles cultures. An updated version of the control will be released soon.

    http://rbrundritt.wordpress.com

    Tuesday, February 10, 2015 10:09 PM
  • The control has been fixed. The main download page will be updated shortly, however our team has also released this as a Nuget package which is available now: http://www.nuget.org/packages/Microsoft.Maps.MapControl.WPF/

    http://rbrundritt.wordpress.com

    Wednesday, February 18, 2015 6:32 PM