none
VS 2015 high CPU usage

    Question

  • I have VS 2015 running at very high CPU usage all the time. What do I do with this problem?

    Thanks

    Friday, November 13, 2015 2:22 PM

All replies

  • Hi markgoldin,

    You can try to disable git in Source Control if you dont use it all the time. Sometimes enabled git plug-in can increase your CPU usage. To disable git plugin go this way:

    Tools -> Options -> Source Control -> and than set Current source control plug-in to None

    Best regards!
    (I hope this was helpful for you, if it was propose it as an answer.)

    • Proposed as answer by Almir Vuk Friday, November 13, 2015 3:03 PM
    Friday, November 13, 2015 3:03 PM
  • Really? Should I also turn off a half of other features? I am using TFS and working with TFS  is a big part of my overall usage of VS.
    Friday, November 13, 2015 3:13 PM
  • Thanks for Almir Vuk's reply.

    Hi markgoldin,

    Which Visual Studio 2015 version are you using? If run Visual Studio without any solution, just open it, does it have this problem?

    Please try Almir Vuk's suggestion first to make sure whether this problem is caused by the source control you are using.

    Visual Studio CPU high usage is a common problem, it can be caused by different reason. Create a new project to check ,whether it occurs with just a specific project or all type project.

    If for a specific project, please try with following steps to troubleshoot this problem.

    1. Run your solution in another computer, if it has the same problem, it related to your solution. If works fine in another computer, it related to your Visual Studio.
    2. Please confirm all files opened by Visual Studio in your project is included in project. If not, please right-click to Include it into project.
    3. Please close all designer editor in Visual Studio, such as XAML designer, which will consume some CPU and Memory to render the interface.
    4. Delete the .suo file in solution folder, which saves user settings for current solution.
    5. Create a new blank project and the remove the files one by one to confirm which file causes this problem.

    If for all type project, please try with below steps.

    1. Run Visual Studio 2015 as Administrator.
    2. Run Visual Studio in safe mode with "Deven.exe /SafeMode" to prevents all third-party VSPackages from loading when Visual Studio starts, thus ensuring stable execution.
    3. Uncheck "Automatically adjust visual experience based on client performance", "Enable rich client visual experience" and "Use hardware graphics acceleration if available" option in Tools -> Options -> Environment tab.
    4. Disable the diagnostic tools under TOOLS->Options->Debugging->General.

    Best Regards,
    Weiwei

    Monday, November 16, 2015 5:19 AM
    Moderator
  • I have VS 2015 running at very high CPU usage all the time. What do I do with this problem?

    Thanks

    Why is that an issue? Is the PC going to explode?

    Upgrade to a higher performance PC. CPU's are there to be used.


    La vida loca

    Monday, November 16, 2015 5:28 AM
  • Less resources for other processes??
    Monday, November 16, 2015 2:26 PM
  • Once I open solution, the CPU usage goes up. I tried:

    1. Uncheck "Automatically adjust visual experience based on client performance", "Enable rich client visual experience" and "Use hardware graphics acceleration if available" option in Tools -> Options -> Environment tab.
    2. Disable the diagnostic tools under TOOLS->Options->Debugging->General.

    • Edited by markgoldin Monday, November 16, 2015 2:44 PM
    Monday, November 16, 2015 2:43 PM

  • Why is that an issue? Is the PC going to explode?


    Hi MMB,

    this *is* an issue. Your electricity bill will show. The resources of our home planet will thank you for using less cpu power.

    Regards,

      Thorsten

    Monday, November 16, 2015 2:51 PM
  • The same solution opened in VS 2012 does not have that problem. "Visual Studio CPU high usage is a common problem", I see that.
    Monday, November 16, 2015 3:32 PM
  • Hi,

    does the high cpu usage lower after some time (some minutes)? That's the issue here. when working with solutions the cpu usage will be high with an incredible slowdown of intellisense for about 5 or more Minutes. Then things are going somewhat better.

    Regards,

      Thorsten



    Monday, November 16, 2015 3:37 PM
  • No, it does not lower. It goes up as soon as a solution is opened and stays. Also very often after closing VS devenv.exe is not disappearing from the Task Manager.
    Monday, November 16, 2015 3:43 PM
  • No, it does not lower. It goes up as soon as a solution is opened and stays. Also very often after closing VS devenv.exe is not disappearing from the Task Manager.

    hm, not an issue here. The only things that are kept a while in task manager are those VS-Hub things, some compilers and the conhost stuff...

    Regards,

      Thorsten

    Monday, November 16, 2015 3:54 PM
  • HI all, Same thing with Visual Studio 2015 Professional,  and sometimes when i close VS launches an error "Visual Studio has a unexpected Error", then i must close it by Task Manager. 

    Adding some information,  i working with TFS and ASP.NET MVC with EF, so i cannot turn off the source control. It's a very buggy version of Visual Studio.

    Saturday, November 21, 2015 4:21 PM
  • Any resolution on that? Enterprise version has the same problem. It seems like working mostly with JS is causing it. Are there any alternative development environments?
    Sunday, January 17, 2016 8:25 PM