none
Azure Data factory copy source selection error

    Question

  • Hi,

    I have been using ADF for a while now. I was able to configure source, sinks etc and was able to copy data successfully until yesterday.

    Starting this morning, I have been getting an error " SyntaxError: Unexpected token o in JSON at position 1". I was only using an existing source and i am getting this error all of a sudden. I tried connecting to different sources and used different browsers but to no avail.

    Can you please help me resolve the issue. Any solution is greatly appreciated. Thank you.

    Tuesday, November 6, 2018 3:41 PM

All replies

  • Hello,

    To clarify, are you only getting this error when trying to create a new copy activity with any linked service source?

    Tuesday, November 6, 2018 6:47 PM
    Moderator
  • No. I actually started to get this error with pre-defined connections. It is not limited to any source - it happens with blob, SQL DW, SFTP linux server etc. All give the same error.

    Hence, I also tried re-defining the sources as new connections and still see the same error either way.

    I also tried editing existing pipe lines trying to connect to the sources via Author mode and still see the same error.

    What is surprising is something underlying in ADF might have changed. I also tried different browsers. I am only trying to 'use' a predefined source and the JASON format error comes up. Any help is greatly appreciated.

    Tuesday, November 6, 2018 8:15 PM
  • Hi,

    We are facing the same error. 

    If I try to use the copy data using an existing data factory, we get the "SyntaxError: Unexpected token o in JSON at position 1" error.

    I tried creating a new data factory and was able to get through. 

    Any help in fixing the existing data factories is greatly appreciated.

    Thanks



    • Edited by coder_st Tuesday, November 6, 2018 9:01 PM
    Tuesday, November 6, 2018 8:43 PM
  • Hi AzAdit and Coder_st, it happens when testing connection/preview data or other operations in ADF portal, right? Does it happen when you run the pipeline?
    Wednesday, November 7, 2018 3:05 AM
  • Hi Fang,

    Yesterday we were unable to run the existing pipelines also yesterday. Interestingly, things are running fine today. Not sure if there was any change that was pushed?

    Thanks.

    Wednesday, November 7, 2018 3:40 PM
  • Yes. We disabled a feature yesterday. Your UI operations like test connection, preview data will fail with the feature eanbled. But it should not affect the pipeline run. Were you using debug run or trigger run?

    So now both UI operations and pipeline running are working fine now, right?

    Thursday, November 8, 2018 2:59 AM
  • Sorry I had to create a new login as my old one (azadit) wasn't working anymore.

    Yes , starting 11/7, it started working ! . It appears both test connection and pipe lines are working. On 11/6 when the issue started, executing already created pipe lines were working normally but even to select an existing data source for a new pipe line was failing.

    The problem was to create any new pipeline, we have to choose a source. And no matter what source it is, it was failing with Jason errors and it held up a lot of work. It is not merely about testing a connection vs running a pipe line - it was about not being able to create any new pipe lines.

    Any help to avoid these issues will be much appreciated. Thanks.

    Friday, November 9, 2018 8:58 PM
  • Are you still hitting issues? Could you give more details? Screenshot?
    Monday, November 12, 2018 10:35 AM
  • Hi Fang,

    No, we are not facing any issues currently. We can consider this closed.

    I was more referring to any chance of avoiding the adhoc issues in future as it holds up work and we can't trace if its a code issue or an issue with the tool as such.

    Thanks for the help and responses all the way !

    Regards.

    Monday, November 12, 2018 10:08 PM