none
ASP.NET and IIS 7 running on Vista Home Premium RRS feed

  • Question

  • Hello,

    I'm trying to setup a development machine that is running Vista Home Premium. 
    I have IIS-7 installed and Visual Studio 2008.
    I have created a virtual directory in IIS and added the IIS_IUSR user with permissions.
    I create an ASP.NET app in the physical directory.
    When I go to http://localhost/Mytest I get the following:

    You do not have permission to view this directory or page because of the access control list (ACL) configuration or encryption settings for this resource on the Web server.

    Detailed Error Information
    Module IIS Web Core
    Notification AuthenticateRequest
    Handler StaticFile
    Error Code 0x80070005
    Requested URL http://localhost:80/TestWeb1
    Physical Path C:\Users\David\Websites
    Logon Method Anonymous
    Logon User Anonymous

    Visual Studio works fine if I press the F5 key to run the app, but I can't run it on it's own. 
    I've seen posts that say only Vista Unltimate allows Windows Authentication, but is there not some way I can make this work just for my own testing?

    Thanks so much,  --David
    Thursday, July 16, 2009 8:48 PM

Answers

  • This will solve your issue.
    Abhishek Shukla MCP WPF
    • Marked as answer by YiChun Chen Tuesday, July 28, 2009 2:27 AM
    Friday, July 17, 2009 8:18 AM
  • Thank you for Abhishek's help.

    Hi --David,

    This forum is for the support of .NET Framework installation. Since your issue is related to ASP.NET, you could post your thread on ASP.NET Forum. This will make answer searching in the forum easier and be beneficial to other community members as well.

    Thank you for your understanding.
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by YiChun Chen Friday, July 24, 2009 3:08 AM
    Monday, July 20, 2009 7:56 AM

All replies