DreamSpark Download Issues - Update 2/8/13 RRS feed

  • General discussion

  • Hey Folks,

    We've had a spike in posts here about people having issues with DreamSpark, and there hasn't been a corresponding spike in resolutions from the community, so I thought I'd drop an update here.  

    If you're having trouble with your DreamSpark downloads, particularly using the Secure Download Manager, or unpacking files after they've finished downloading via the SDM, this post is for you.  The Kivuto team supports the download process and the Secure DOwnload manager.  

    The Kivuto team is working hard on resolving reported problems, and I've been in contact with them over the past few days about the spike in reports here.  If you are having issues, here's what you should do:

    1) make sure you've tried uninstalling and reinstalling the SDM.   You can uninstall it just like any other windows program by going to your control panel and clicking to uninstall it.  I believe re-attempting a download will prompt you to reinstall it.

    2) If after uninstalling/reinstalling you still have issues: make sure you have a case number with the Kivuto DreamSpark support team.  Posting here in this forum will not get you on their radar.  You can get a case number by emailing DreamSpark@Kivuto.com.   

    Thanks and have a great weekend.

    Update 2/8/13

    Howdy Folks, another update here.   Although some improvements have been made, we still see and hear your reports of issues, and are acting to try and resolve thing.   We've had a few more people assigned to work this problem, but they need more data to work with, and I know that the folks who are continuing to see issues are extremely excited about getting this resolved.

    I've been asked to reach out to you to submit information to the Kivuto team that can help them identify each of the problem download sessions on their servers. They need specific information about individual download attempts and that means they need to know the date and time and problem and location and ip address and all of the specifics for each attempt.  We know you're frustrated, but we're going to go into the logs with tweezers, so rather than letting us know "last Tuesday it wasn't working for me or my friend" here's what I hope you can do:

    1. Make a note of the exact time of the day, and start a new download.  This will help them look in their logs to find the exact event on their side.  (you should also probably note your timezone!)
    2. Note exactly what file you downloaded. 
    3. When you get an error, make a note of what the error is, and any other details about it that describe it (i.e. it happened at 38% complete, include a screenshot).   
    4. Identify your DNS IP address by navigating to: http://www.damia.com/whatismydns/.  
    5. Identify your IP address at http://whatismyip.akamai.com.  
    6. The resolved ip address you see for software.dreamspark.com.  You can get this by opening a command window (click start, then type cmd), and then at the prompt typing "nslookup software.dreamspark.com."  and noting the output Addresses
    7. Your location.  I don’t think they need any more information than what State or Country you're in

    If you want to make multiple attempts, and send in a single email with all of those attempts, that’s fine.   

    Send all of this information into dreamspark@kivuto.com.  This should give them the amount of data they need to understand where the failures are occurring and help us understand what it will take to fix them.  If you already have a case open with DreamSpark you should include that as well, and please try to provide -all- of these items, not just a few of them.  What we will do is group them by error type and by customer location and begin trying to solve each of those sets of problems.


    MSDN and TechNet Subscriptions Support
    Read the Subscriptions Blog!

    Friday, November 30, 2012 8:14 PM

All replies

  • This must be a joke. This whole system has to gone. It is just ridiculous. I'm searching the ISOs on Google now downloading them via some torrent or open FTP which hosts the file.

    I'm really sorry but a solution can't be the reinstallation of the programm neither some case number. If they don't read here and you can't show them this thread then it's completely pointless. I just can't wait for a case number neither does anyone out there want this Secure "Download Manger".

    From my point of view the SDM has to gone. It's as simple as that.

    Thursday, December 13, 2012 8:04 AM
  • I completely agree with this. What planet or decade are you living on where "uninstall and reinstall the download manager" is considered acceptable advice? Hey, maybe I should defrag my hard drive and update my display drivers. I thought we left consistently failed downloads and download managers that don't work at all in the 90's. 

    Been trying to download Server 2012 for three days now, on windows and mac; takes about 8+ hours to download, twice has completed and said "Cannot extract, please download again" (what, so this 3gb of data is useless? I thought part checking/parity files were long, long ago solved), got to 99% and then say there for three hours not doing anything, then crashed (and on reopening, just sat there for ten minutes doing nothing and crashed again, ad infinitum until I manually removed the partial downloads). This isn't even counting the number of times I had to sit and restart the process because it never starts pulling data at all. Right now, it's done 42% and has stayed on "Time remaining: 00:22:48" for the past 10 minutes.

    I'm hoping that the downloads I can find through googling the iso/torrents take my dreamspark key, but can't seem to find any shasums listed for the iso, so can't even verify that it's the legitimate same.

    Incidentally, VS2012 worked fine, but that's probably because I got the 2mb web installer, that downloaded the rest itself.

    • Edited by Xgkkp_ Saturday, December 15, 2012 12:50 AM More Belligerency.
    Saturday, December 15, 2012 12:42 AM
  • Yes I agree with you also. The program has NEVER even worked once for me. Downloads keep freezing in the middle, extraction fails after 10+ hours of downloading, downloads don't start at all and you have to keep trying 20 times. It seems this program and the unbelievably slow download servers are a deliberate effort, because every undergraduate student could write a better download manager in a matter of hours.

    thank you,


    • Edited by matsu9900 Friday, December 21, 2012 4:40 PM
    Friday, December 21, 2012 4:37 PM
  • The SDM is a failure by design.

    I have to download everything at least 2-3 times before it works. It is right now the 4th time i start the download for SBS 2011.

    I don't care about the kyuto support. The issue is NOT with my System. It is with a download manager that just simply sucks.

    Why can't we get direct downloads like we had in the, not so long ago, past? There is not a single advantage of that SDM for the user. Maybe there is for Kyuto and Microsoft, but not for your users.

    And dropping the complete File because a small amount of data on it is corrupt? Maybe you should look at the torrent protocol to see how it is possible to figure out witch part of the file is broken, and only re-download that small chunk.

    If we had direct links, i could at least use a working download Manager. I would gladly take the risk of that download being corrupt.

    Also SDM seems to be extremely slow with downloads. I'm on a 100Mbit line, and yet it still takes ages to download stuff.

    The SDM also gives no information about the current download speed or anything.

    Why wont you switch over to something working? Direct Links, or maybe torrent?
    The alter might even be an advantage for you, because the servers would have less traffic.

    An aborted or corrupted download can be resumed and fixed really easy. And even torrent files CAN be protected from sharing with others.
    One time Passkeys bound to the users IP address.

    Anyway, the only thing i can say is, get rid of SDM or at least give us an alternative option! I'm seriously starting to doubt Microsoft products at all at this point. Yes the SDM is not developed and maintained by you. But you should be able to get somebody doing that who knows what the heck is doing anyway.

    Friday, December 28, 2012 8:21 AM
  • SDM is really slow on mac and yet most of the times it gives errors when its unpacking the files that has been waited to download for hours. Why don't  we use direct  links ??

    I have 50Mbs connection and used more than a computer with similar results. 

    Monday, December 31, 2012 11:11 PM
  • Hello,

    This is ridiculous. I have wasted half of my day trying to download software with a broken download manager only to be told that my fix is uninstalling and then re-installing said broken piece of software, or to contact them with a case number, that I have to get from them in the first place!... Am I to waste another day or two trying to tell them their software doesn't work, while being asked to re-install it yet again...?

    I feel really frustrated by being put through this rigor just to download a piece of software. Just give us a direct download and have done with it! Or give us Linux!

    Kind Regards,


    Sunday, January 13, 2013 11:30 AM
  • So, when I've uninstalled and reinstalled, found that SDM still doesn't work and reported it to Kivuto and got a case number, what happens next?

    The software is terminally broken and it gives a very, very bad impression of Microsoft. We bought Dreamspark Premium for our students because we wanted them to have access to a great range of software. What they now have is an impression that Microsoft provides utterly broken download software (and I know that it's not Microsoft that provides the software. They might know that but they don't care - they're downloading Microsoft programs and they expect Microsoft to provide a solution which works).

    Microsoft have presumably paid Kivuto to provide a service; Kivuto is failing miserably to do it (and taking 4 weeks to respond to calls as they did on one of mine just adds insult to injury!)

    Someone at Microsoft needs to get this fixed!

    Steve Rochford
    Imperial College London

    Monday, January 14, 2013 9:34 AM
  • Hey Steve,

    can you shoot me a site feedback by following these steps?

    1) visit http://msdn.microsoft.com/subscriptions

    2) click site feedback

    3) reference this thread in the body of the feedback.

    I'd like to get your Case number with Kivuto and follow up with them about where the breakdown is.


    MSDN and TechNet Subscriptions Support
    Read the Subscriptions Blog!

    Monday, January 14, 2013 5:39 PM
  • I also was having problems downloading with SDM.

    It would halt repeatedly, but at least "resume" worked. But when I got to the end, there was an "Unpacking error. Please try downloading again."

    I contacted tech support (by emailing DreamSpark@Kivuto.com). Dave replied, and asked me to try several things. The one which worked was very simple: try using a different internet connection. My friend tried it on his high speed connection, and it worked flawlessly.

    Although I was also frustrated, like everyone on this thread, Dave asked me to stop and think: tens of thousands of people are downloading from Dreamspark. If SDM had a fatal flaw, they would be completely flooded with requests for support. That's simply not happening. It's only a relatively small number of us that are having this problem. And thankfully, he was able to steer me in the right direction.
    Wednesday, January 16, 2013 6:23 PM
  • Where can I say this system suck so that Microsoft can actually hear me?
    Thursday, January 17, 2013 12:29 PM
  • How on earth is it possible to need 12 hours to download 80% of 2 GB in 2013? FIX NOW!

    And when its done i will probably get an error (facepalm)...

    Thursday, January 17, 2013 6:19 PM
  • The Download Manager is TERRIBLE!!!! slower and more crashy than just downloading using browser. What was wrong with just downloading the ISO using standard HTTP? This worked and was faster (provided you didn't use IE :P)

    SDM does not reduce piracy as once the "wrong" person manages to download the ISO with SDM, after 5 or so failed attempts of course, they can still easily make a torrent allowing others legally and illegally download the ISO!

    Please let me know why you require SDM? and why you didnt use a Download Manager that supports resuming if the connection is interrupted, and has error checking. if SDM is interrupted it either crashes and makes you start again or gets to 100% and fails validation!

    Thursday, January 17, 2013 7:32 PM

  • This is f-ing bullshit. Lost connection after 4 hours of 1h42m remaining and it cant even check whats downloaded? Seriously!

    There is no way in H it should take this long! Fix your program idiots! People pay for this... No wonder "piracy" still exists.

    Thursday, January 17, 2013 10:52 PM
  • Thought I'd weigh in on this too,

    Myself and a classmate both having the same problem of Windows 7 not being able to complete downloading, just hangs and dies at about 34%. Kivuto offered no help, and just told me to contact my program administrator.

    Friday, January 18, 2013 6:53 PM
  • I have the same problems. SDM doesn't finish any of my downloads. It gets stuck at some point and does not resume. Please Microsoft make the downloads available from your servers or at least kick some butts at Kivuto.
    Saturday, January 19, 2013 1:34 AM
  • I have the same problems. SDM doesn't finish any of my downloads. It gets stuck at some point and does not resume.
    Cant something be done to make it work properly?
    Thursday, January 24, 2013 7:48 PM
  • Yep, I am also having issues trying to download server 2012 datacenter. Tried at least 5 times now. Every time it gets stuck at 50% and then does not continue. Anyone care to post a link to a torrent of server 2012 that will accept my dreamspark code?
    Friday, January 25, 2013 11:31 AM
  • I have tried to use SDM to access applications in my MSDN account and have *never* been successful.

    I have tried on different networks, different hardware, different operating systems (Win 7 64 bit and Win XP 32 bit). The program *never* downloads *any* bits of information; it's always at 0%. There's always The Pirate Bay, but that's not an acceptable option, especially in a workplace setting.

    Microsoft did the right thing with Windows 7 ISOs being hosted directly on digitalriver. Why are all other MSDN applications requiring SDM? If it ain't broke, don't fix it. And if it (SDM) is broke, just give us an FTP server for crying out loud!

    Frankly, you can take your broken SDM and stuff it where the sun doesn't shine.

    Friday, January 25, 2013 4:53 PM
  • Hello,

    It's the same for me and for all my colleagues here in France. We have tried all the propositions to success the download. Nothing to do.

    It's really sad... We don't want to buy Office 365 University because we are afraid to not download it.

    SDM has to be fixed quickly.


    Dr. A. Florentin

    Saturday, February 2, 2013 9:40 AM
  • ARGH! $%&/()='*

    Why does MS need to serve its products via SDM? We all payed for our subscription, so I believe we are all important customers for MS. Right?

    So why does MS spent so much time for the other side, for those "customers" who doesnt pay?

    I mean, the idea of SDM is to have secure downloads, to prevent people from getting the products illegaly? They cant be stopped!

    I tried for the 10th time to download something. Thats enough!

    Gonna take Eclipse, gonna build for google.

    Bye bye MS!! 

    Sunday, February 3, 2013 11:43 AM
  • An update from our folks:

    It appears that the download issues are limited to some countries in Europe, namely Ireland, UK and Germany, all though we have seen some reports in other countries as well. The issue is related to the hosting service and we are currently investigating this further to ensure that we provide a prompt resolution.

    We suggest that if you are experiencing issues, you contact your ELMS webstore administrator at your institution so that they can escalate this to Microsoft through our partners Kivuto Solutions and provide us all the necessary details. This will allow us to trouble-shoot the issue and provide a faster resolution.

    We're happy to see that some users are reporting improvements but we are continuing to work this problem.

    Thanks for your patience!


    MSDN and TechNet Subscriptions Support
    Read the Subscriptions Blog!

    Monday, February 4, 2013 11:49 PM
  • Seriously!?

    After so much wasted time trying to download, after months Kivuto was blaming the users, their firewalls, antivirus programs, ISPs etc. someone finally noticed that there is something wrong with MS's download servers.

    I don't know what to say, but MS has to seriously think about its relation to the users/customers.

    Tuesday, February 5, 2013 3:32 PM
  • I've had a 10% success rate with SDM when downloading anything 1 GB or larger. I live in Florida, United States. I have tried on different ISPs and all. The issue is the software or corrupt files on the server.

    All attempts through https://www.dreamspark.com/

    Unpacking error.

    Thursday, February 7, 2013 4:34 AM
  • Everyone, please see the updated post at the top of this thread.



    MSDN and TechNet Subscriptions Support
    Read the Subscriptions Blog!

    Friday, February 8, 2013 10:41 PM
  • so frustrating!!!!! no way to download with sdm!! should be removed and made easy for users! i wonder if this is really "microsoft" we are dealing with. it would be easier to change for another operating system than to go through all the hassle described in this update after all the pain we had and also not sure to get a solution.
    Saturday, February 9, 2013 12:26 AM
  • Mr. Kinsman, after three failed attempts to download the three gigabyte windows 8 file. I follow the above directions and e-mailed kivuto on saturday. Today I recieved the following resonse:

    Thank you for contacting us.

    In this situation you will have to contact your local Program Administrator(PA) for
    your MSDNAA site. You can find their contact information by going to the Support page
    on your site. Just in case, their e-mail is *************.

    Please contact your PA for this and any other questions or issues that you may have
    regarding your MSDNAA site.

    Kind Regards,

    Technical Support Specialist
    Kivuto Solutions

    Monday, February 11, 2013 10:34 PM
  • *grumble*   Thanks very much for letting me know ibnzbssrckr.   I'll give them a shout. 



    MSDN and TechNet Subscriptions Support
    Read the Subscriptions Blog!

    Tuesday, February 12, 2013 3:06 PM
  • Hi Mike,

    I sent them the debugging info as specified and I just got this back:

    •  Thank you for contacting Kivuto solutions.

      In this situation you will have to contact the local Program Administrator (PA) for your DreamSpark WebStore. Their contact information (which can usually be found on the “Support” section of your WebStore) is:

      Please contact your PA for this and any other questions or issues that you may have regarding your DreamSpark site. 

      Kind regards,
      Technical Support Specialist
      Kivuto Solutions Inc.

    Are you sure they're taking this issue seriously? I am completely unable to download any of my products and they are neither providing alternate download locations as requested or providing any real support at all.

    I shouldn't have to hunt around seedy sites to get my ISOs. This is shameful performance and reflects badly on Microsoft. What's the point in paying big $$$ for a Dreamspark Premium contract if this is what we get in return?

    • Edited by Adrien J Tuesday, February 19, 2013 12:09 PM
    Tuesday, February 19, 2013 12:16 AM
  • Hey Adrien

    I've heard from them this morning about your post, and I'm working with them on clearing some things up.  There are a few different issues that have been reported, and I think *some* of them they're able to address through their investigations on network performance, and others do really need to be addressed by your Administrator.  

    I'll clear this up with them and update my post to clarify what should be done for different types of issues, and what type of help your PA will be able to provide.

    I definitely didn't mean to waste your time when you gathered this info, only to be told "nope, go somewhere else" so sorry about this.  Stay tuned.



    MSDN and TechNet Subscriptions Support
    Read the Subscriptions Blog!

    Tuesday, February 19, 2013 6:03 PM
  • Adrien, 

    I'm in discussions with them.  What problem did you report?

    Also, I think it still might be the right idea to contact your PA, to make sure they're aware of the issue as well.   more soon.


    MSDN and TechNet Subscriptions Support
    Read the Subscriptions Blog!

    Tuesday, February 19, 2013 8:37 PM
  • Thanks Mike. I'll inform my PA of the issues too, for what it's worth.

    Here is the message I sent Kivuto:

    • I am encountering crashes your buggy Secure Download Manager system. As
      per the page here
      the following is my debugging information.

      My software downloaded up to 100%, then the SDM crashes with a Runtime
      Error before converting the downloaded file to an iso. When opening the
      program again, the download remains at 100% so I cannot start the
      download fresh. This is true even after the SDM is installed and

      I attempted to resume the DreamSpark - Windows 8 Professional 64-bit
      (English) download at 5:08 AM EST February 17, 2013. A screenshot of the
      error I experienced is attached (note that following the error, the
      progress bar for the download goes to 0%, though it returns to 100% when
      the program is closed and reopened).

      I also started a new download of DreamSpark - Windows 7 Professional
      with Service Pack 1 32-bit (English) at 5:23 AM EST February 17, 2013. I
      did not pause or resume this download, and it completed successfully
      around 6.

      My DNS IP is
      My IP is
      software.dreamspark.com resolves to and for me
      I am located in Ontario, Canada

      Please direct me to an alternate download location for these files since
      your system is unusable for me currently.

      -Adrien Johnson

    I sent the following message immediately afterward:

    • An amendment:
      Even though the download of DreamSpark - Windows 7 Professional with
      Service Pack 1 32-bit (English) download reached 100% and was listed as
      "Done", neither the iso nor sdc file actually appear in the download
      folder. The sdc files for the incomplete and broken downloads do appear
      though. It seems I have actually not been able to download anything.

    The error I encountered is pictured at http://i.imgur.com/VL9j3Np.png

    Wednesday, February 20, 2013 8:11 PM
  • Thanks for the followup Adrien.  We're in discussions with them today, and we're talking about the mixed messages you've been getting from me here and from them over email.

    If you haven't already contacted your PA, please do. I'd like to know what help they have to give you for your issue.  If you want to reach out to me directly over email, so you can forward your interaction with them to me, go to http://msdn.microsoft.com/subscriptions and click "Site Feedback" at the -very- bottom of the page, and it'll get to my inbox. 


    MSDN and TechNet Subscriptions Support
    Read the Subscriptions Blog!

    Wednesday, February 20, 2013 9:26 PM
  • Hi,

    I really need visual studio 2010 for my uni course and unable to get the sdm to download it. Is there any other way that i could download the program as this is putting me very behind in my class.


    Friday, March 8, 2013 10:47 AM
  • Try adding SDM on your Firewall exclusions. It worked for me. The .exe is located in "user folder"/AppData/Local/e-academy Inc/
    Tuesday, March 12, 2013 11:09 PM
  • Anything was workign for me since i see the post of http://social.msdn.microsoft.com/profile/kadir276/?ws=usercard-mini

    Wich is the only solution has working for me :


    And it is very simple : disable the TCP Ipv6 and Qos on your ethernet connection. I have Ipv6 and it doesn't work now it download !! I'm waiting the 100% !!

    Thursday, March 14, 2013 8:44 PM
  • So, here's my story with Dreamdeath.  I have Win 7 Pro 64bit.  Apparently the Microsoft Secure Download tool is not compatible with this Microsoft Operating System.  I could not get it to work in about 2 hours of trying.  Tried running the msi in compatibility mode to no avail. Gave up in frustration last night.

    This morning, I tried it on my wife's WinXP machine and wallah, it worked just fine!  This just confirms my suspicion about Win7 64bit compatibility.  But I had to download the ISO version, copy it  my machine and mount it as a virtual drive.  

    Used VirtualCloneDrive for the ISO mount.  Again issues with Win7 64bit.  But eventually got the installer to work after several stops and starts by running the installer through the Compatibility Troubleshooter.  So MS gets a few points back for that.

    All in all a painful way to start my MS experience!  But hey, thanks for the $13k of free software!  I'm taking a class and need it to do my homework this weekend.  Cheers!

    Saturday, April 13, 2013 6:55 PM
  • Sorry about the download issues MuddyWaterous.  The likely story with your compatibility issue is that 64bit versions of Windows ship with both 32-bit and 64-bit versions of IE, and often the 64-bit version of IE can't load 32-bit plugins.  This is actually the story with our download manager Subscriber Downloads as well.  Please make sure you contact your DreamSpark administrator as well.


    MSDN and TechNet Subscriptions Support
    Read the Subscriptions Blog!

    Monday, April 15, 2013 12:17 AM
  • Dream spark is amazing! not. Windows on my laptop has somehow broken and needs to be reinstalled, so i spend days trying to find someway i can do this legally since i no longer have the boot disk, i find dream spark and think 'perfect!' . So i borrow a flat mates computer and start the process i think will let me have a windows 7 boot disc soon, i download and install the SDM with his permission, i download the .SDX, try to run and simply get a page informing that actuve scripting needs to be enabled for it to work, despite active scripting already being enabled on both IE and his default browser (safari).
    and to top it all off when i request support from Dream spark i simply get a link to this forum, which as far as i can tell the only support it really gives is to tell kivuto, who i already asked for help from, what your problem is.
    • Edited by Brownie Tuesday, May 14, 2013 2:49 PM
    Tuesday, May 14, 2013 2:47 PM
  • Over in MSDN Subscriptions (not DreamSpark), which I support more directly, We get reports about behavior that suggests they don't have active scripting enabled, but then then they check their settings and it is enabled.

    Typically, this is explained by some computer between yours and ours blocking javascript (aka active scripting) for every site on the internet, or only allowing it for certain sites (and dreamspark/MSDN isn't on the whitelist).  You might need to speak to your IT Folks at your University, or check the computer you're using for firewall software that could be doing this blocking.  I've also seen resetting all of IE's settings has gotten around this problem.  To Reset settings, go into your Internet Options, then Advanced Tab, and then Reset... at the bottom of the dialog box.


    MSDN and TechNet Subscriptions Support
    Read the Subscriptions Blog!

    Tuesday, May 14, 2013 2:56 PM
  • I am a professor and the program administrator for our university department. I can report that a percentage of my students, all in the U.S., are experiencing the problems reported here, the firewall/choose another location/error unpacking messages. I can also tell you that when you hit the support request in DreamSpark the message goes to somebody like me and we absolutely do not know anything more than you do. I'm pretty good at doing research to track down issues like this and found this forum and others like it, only to find a dead end.

    I have a couple of suggestions:

    1. Be sure you are using a wired connection.
    2. If you encounter these issues try using a different location and Internet service is possible.
    3. If you are a DreamSpark member the license allows you to trade materials with a classmate or professor who is also a member. That is, if another eligible person in your program has been able to download and create the .iso file they can share the file or a resulting physical disk with you. If your product requires a license key you still need to add the product to your shopping cart and use YOUR key when installing but you can use another copy of the installation media.
    4. Burn a DVD. I've had a few instances where virtual drives don't work and you always want a physical disk in case you need to reinstall.

    I am an application developer and database designer and not well versed in the technical details of networks or operating systems but... many of the posts here and elsewhere are giving indications that the problems lie between DreamSpark and the destination computer. I've got a couple of students currently dealing with these issues and I'm going to try to get them to change locations and retry the downloads. If I find any evidence of the Internet connection as an issue I'll repost here.

    Larry West University of Central Florida

    Saturday, May 18, 2013 2:37 PM
  • I just wanted to let you know that I had an issue with my downloads not starting at all which was resolved by switching from Google's DNS service back to my ISP's default DNS. So if you're having trouble with downloads not starting and using any third-party DNS service, that might be the problem.
    Friday, June 14, 2013 7:08 AM

    I couldn't  begin to download any software, tell me in red a message with alerts about folder and firewall.

    I did, first, an exception in the firewall of SecureDownloadManager.exe and next, execute SecureDownloadManager.exe as administrator and Windows 7 compatibility and finnally i got it.

    I did it alone, without help of nobody, only with my fingers.

     (Yes, my English is very sad, don´t cry more, please, i'm so sorry folks)

    [win8 x64]

    • Edited by dev_gutman Monday, June 17, 2013 7:53 PM
    Monday, June 17, 2013 7:43 PM
  •  Hello:

       I have similar problem with Kivuto Dreamspark.

    My University got me an account to download several files.

    At the beginning I could downloaded 3 software files withouth any problem but suddenly it stops working:

    I have tested in another computer in another connection and it seems to work ok. I don't understand what's the problem with my computer and my connection (I could use it to download some files) and I haven't changed anything, except some Automatic Windows updates.

    I have tried in my connection with another router and with 3 computers (Win 7 32bit, Win 7 64 bit and Win XP) but i doesn't work like if it was no internet connection or there was some problem with firewall. (I disabled windows firewall but the problem is still the same)

    I don't know what to do, I'm really obfuscated

    Kind regards

    Tuesday, June 18, 2013 8:53 AM
  • I am in the middle of downloading Microsoft Windows 8 Professional N 32/64-bit (English). It comes as two .sdc files.

    While downloading the 64-bit version for the n-th time ends in an error message stating that the archive is corrupt, the 32-bit version works just fine.

    This, in my opinion, excludes the possibility of faults on the user side and may suggest faults with the source archives on the server side. I don't see how Internet connection or geolocation can be blamed for some files only.

    Also, I would like to say that no other download system I have encountered is as pathetic and worthless as Secure Download Manager. Please, change the approach, perhaps embracing P2P methods of software distribution.

    Update: it finally worked.

    I made at least 4 attempts, two a few months ago and two today. It is a bad software if it is a matter of blind luck for the user; this shows that the source archives are not corrupt, so the only thing to blame is the SDM itself.

    On a sidenote, I did not pause my download nor changed my network connection in any way during the downloading process.

    Saturday, June 22, 2013 10:49 PM
  • Wow, whatever happened to the pop up that says "not compatible with your system" ?

    I'm glad I finally got your answer. I too need to upgrade for class, but I don't know how to do any of that other stuff you mentioned. Sounds like more hassle.

    Monday, July 1, 2013 2:50 PM
  • Hey, just wanted to say I had this issue just now, my error message was something about location and the download didn't start.

    I remembered I had recently completely disabled UAC via a registry edit. So when I reverted that it worked again.

    The regword is located here:


    After setting that to 1 again I could dowload my 700kb webinstaller. Yay.

    Wednesday, July 10, 2013 4:10 PM
  • Solution seems to be simple, disable internet connection and enable it again, as you will thus acquire new IP address and "software" will miraculously start working.
    Monday, July 15, 2013 11:26 PM
  • I already tried to get support from the Kivuto Support...

    They said that I had to get support from my Program Administrator.

    All the informations you need was in the mail...

    Friday, July 19, 2013 6:24 PM

    I couldn't  begin to download any software, tell me in red a message with alerts about folder and firewall.

    I did, first, an exception in the firewall of SecureDownloadManager.exe and next, execute SecureDownloadManager.exe as administrator and Windows 7 compatibility and finnally i got it.

    I did it alone, without help of nobody, only with my fingers.

     (Yes, my English is very sad, don´t cry more, please, i'm so sorry folks)

    [win8 x64]

    Try the above if you are having issues. I did and it worked. i didn't have to add firewall exception though. Just run as admin and windows 7 compatability. and Bam! its working again.

    Sunday, July 21, 2013 1:44 AM
  • Resolved:

    1. Open your .SDX with notepad.
    2. Copy that single line and paste on your browser.
    3. Save the whole goddam page on your desktop.
    4. Open the .html with notepad.
    5. Locate two lines similar to those:




    notice the 01 and 02 on the end, before .sdc

     6. Download these files.

     7. Go here and download "unpacksdc":


     8. Follow the instructions and be happy.

    • Edited by LucasDeMH Monday, July 29, 2013 4:57 PM more info
    Monday, July 29, 2013 4:56 PM
  • This is how i got it to work

    In short, you download the .sdc files and feed them to the SDM with a local HTTP server

    1.  Open the .sdx file with notepad and open the URL in your browser. View the HTML code (CTRL+U in some browsers) and search for something like:
    2. Navigate to those URLs you just found to download the files. If instead of the file you get an error page with a link, try following that link. Or try replacing 'software.dreamspark.com' with 'dreamspark.blob.core.windows.net'.
    3. Download an HTTP server (nginx is ok, zero config), recreate the dreamspark URL's directory tree in your server's document root, and copy the .sdc files there. eg:
      Start the server (eg execute nginx.exe)
    4. open the hosts file with notepad as Administrator (the hosts file is located in C:\Windows\System32\drivers\etc\hosts) and add the following line software.dreamspark.com
    5. use SDM to download as usual, it should work. If you have problems with this last step, try running 'ipconfig /flushdns' from cmd (or rebooting)

    Wednesday, August 7, 2013 2:09 AM
  • really interested in the last few posts that have come in.  Has anyone had luck implementing these solutions as workarounds?


    MSDN and TechNet Subscriptions Support
    Read the Subscriptions Blog!

    Wednesday, August 7, 2013 8:05 PM
  • It worked for me, although figuring out how to unpack the sdc took a while. It would be great if you guys could just offer direct downloads ;)
    Thursday, August 8, 2013 3:03 AM
  • it's exactly what i thought:

    Every undergraduate student could write a better download manager in a matter of hours.

    Yes we pay few dollars, but 3 years ago MSDN for students was a breeze..

    Sunday, September 29, 2013 2:26 PM
  • completely agree.

    and what about the ridiculous registration page?

    every undergraduate student could write a better page in minutes.

    Sunday, September 29, 2013 2:28 PM
  • This initial discussion started inAug of 2012, are you telling me I came here in hopes to find a solutions and it is still not resolved on 10/9/2013? 


    Wednesday, October 9, 2013 10:58 PM
  • solution for unpacking error
    1.open .sdx file in notepad ...
    2.copy all and paste it in the address bar of your browser and open it.
    3.go to source of the file and locate http://software.dreamspark.com/dreamspark/ENGLISH/********************.01.sdc

    4.download these 2 files using your downloader.
    5.open cmd and switch to the location where you downloaded the files  and type " copy /b *******.01.sdc+******.02.sdc 03.sdc ".
    6.open secure download manager start downloading your software when downloading starts go to the location where your software is downloading .... you will find the file ************.sdc now change the name of  the 03.sdc file with the name of the file in download folder now close secure download manager.
    7.Delete file which is in download folder and place file you renamed (****.03.sdc) in download folder.
    8.restart downloading your software with SDM it will work and it will not give unpacking error i tried it 100% successfull.
    sorry for my bad english.

    • Edited by Fahad Mir Tuesday, October 15, 2013 2:13 AM
    Monday, October 14, 2013 1:35 AM
  • I'm going to go ahead and start by mentioning that I feel SDM needs to be phased out.

    For me, SDM would not make it past 0%. Even when traffic shows up in wireshark, 0% is all it will give.

    Here is the solution that fixed it for me:

    1. Run it with Administrator privileges. I ran command prompt as administrator and started the program from there.

    2. Make sure following domains are in Trusted sites -list. (See: Internet Options -> Security)

    • http://e5.onthehub.com
    • http://static.onthehub.com
    • http://ajax.googleapis.com


    Wednesday, November 13, 2013 4:15 AM
  • where can i get

    http://software.dreamspark.com/dreamspark/ENGLISH/********************.01.sdc link ?  

    • Edited by Hari Bonda Friday, November 15, 2013 1:08 PM
    Friday, November 15, 2013 1:07 PM
  • where can i get

    http://software.dreamspark.com/dreamspark/ENGLISH/********************.01.sdc link ?  


    You need to have access to DreamSpark ELMS Webstore. If yes please tell me i will guide you.


    Sunday, November 17, 2013 5:18 AM
  • The issue I'm running in to is that I get this message:

    "The download cannot be completed. If a location selection is available for this product, select another location. If no location selection is available, the download may fail to complete because no Internet connection was found, the Internet connection was lost or a firewall or proxy server exists between the client station and hosting location. Please try again later."

    The process of downloading a file ends up kicking my router off the internet, Then tells me that message. If it didnt kick my router off line it would download just fine is there a specific way the router needs setup? because everything else works fine.

    Wednesday, November 20, 2013 2:28 PM
  • Wow!! It's been more than a year and you still haven't resolved this issue... Despite being under the brand name "Microsoft" you guys are the most ignorant people I have ever seen... How long does it still take to resolve this matter.... 
            Somehow I managed to download till 100 % but Bam!! Your SDM doesn't  extract the downloaded product, I mean SERIOUSLY!!!! I have tried three times but your download manager is so good it wouldn't let extract the file because they want to download so clean product not a corrupted one!! *clap* *clap*

    Thursday, November 21, 2013 5:37 AM
  • Hello all,

    I fixed problem on simple but strange way so tray it, I do not guarantee that it going to solve your problem as well but it worth a try.

    Past 15 day's trying to download VS 2013. After 7 day's of try's couldn't even download SDX file as clicking on download icon did nothing at all. Suddenly before 2 day's it started to give some results on clicking download, it downloaded SDX but after clicking on it , MS Download manager starts and do nothing just not responding msg on top of its screen, and it was like that  till today. Today got an idea , strange and simple , all the time was using Google chrome for everything so used it for this as well. Have no idea how it affect download manager  but when I downloaded same sdx file from IE 11 and opened it from IE it started download manager instantly and started downloading what I wanted in a sec, till  I writing this , 2 GB of VS 2013 is downloaded. So have no idea how and why this happen but that is what happen. Same was case with downloading windows 8 enterprise from MS volume licencing service , for my company where I working , was trying over a month to download it from Google chrome browser without success but first time I tried from IE 10 it started and downloaded what I needed. On Volume licencing service it do not use same download manager, it using browser integrated download manager.

    Hope this helps at least some of you who have problems with ms download manager. Use internet explorer .

    Sunday, December 1, 2013 5:50 PM
  • MSFT sucks !!! I tried downloading using MAC and was able to download 0% in an hour. Tried Chrome browser on windows and got big red error messages. Finally was able to download it using IE 11 on WP8.1 after trying on various OS, browsers and internet connections.

    I don't know what to say, most people in the world still use windows. Despite this they failed to deliver a usable mobile OS. MSFT is a company run through Indian/Chinese developers, who are the least innovative people. 

    Friday, January 17, 2014 6:36 PM
  • Maybe I found a solution, at least it worked for me.

    i was stuck on 99% downloading windows 8 pro 64 iso, no data transfer or anything tried all solution listed everywhere, nothing worked.

    then i looked in my download folder, found the file SdmAuthorize.aspx, decided to delete it and the download finished and the iso was unpacked correctly! :D

    hope it works for someone else

    Sunday, January 19, 2014 11:30 AM
  • Actually, the same discussion has been going on since 2009, on various boards besides this one.

    And yes. There is still no resolution.

    It is now the year 2014. Dreamspark Secure Download Manager still does not work properly.

    Did they ever stop to think that maybe because the reason there has been such a spike in complaints/problems, and no corresponding spike in resolutions, is because the quality of the software... REALLY IS JUST THAT BAD?!?!?!

    All they would have to do is have at least one single programmer (or even two if they REALLY want it to be good!) spend a short time and write a downloader that:

    1. verifies clean or flaky connectivity and accurately reports detected issues.

    2. downloads the entire file, or pieces of it, in a non-linear fashion, similar to bit-torrent.

    3. allows resuming failed downloads without forcing the user to re-start a linear download from the beginning.

    4. allows retries of bad download chunks

    5. shows you MD5 and/or other hash of downloaded file compared with expected result, detects location of error and re-downloads bad chunks automatically until all errors are no longer present and the hash matches.

    5. accurately reports any problems associated with decrypting, decompressing, or otherwise processing the downloaded .sdc files

    6. allows you to fix the problem, and retry the processing of downloaded .sdc files without having to re-download them.

    Here's another idea. let us download the .iso files via FTP.

    in other words, the developers of the SDM seem to have NO INTEREST whatsoever in whether it works for you.

    And that's the real problem.

    Monday, January 20, 2014 5:40 AM
  • Is there a real solution to any of the problems with SDM yet?

    Uninstall/Reinstall is not a "real" solution - did that many times. it has nothing to do with why the same problem happens on every computer on every network in every location, and to hundreds or even thousands of unrelated people all throughout the world. Ya. must need to re-install. not!

    contacting techsupport is not a "real" solution. when the SAME problems are happening to everyone, everywhere, behaving as though it is a strange and unique problem that has never been seen before and needs to be troubleshot by searching the server side logs to find the mysterious magical log entry that will shed some great light on everything (even though the issue happens on the local end-user machine) is not the right way to handle it.

    deleting unrelated files that have nothing to do with the process is not the way to handle it.

    using a different browser is not the way to resolve an issue with a local standalone executable application that has nothing to do with any web browser is not the answer.

    what is right is explaining clearly and concisely what has been found to cause the problems and why, explain the solutions to fix these things, and provide links to youtube videos demonstrating legitimately (no pausing until after it has already "worked"!) what the problem is, how to resolve it, and proving back and forth that under one condition the problem happens and under another condition, it does not. Then allowing the solutions to propagate through the community (aka "go viral") so that everyone knows the problem is solved, and all the posts change from "MSFT sucks! Bah, stupid thing doesn't work! etc, to "Solved it, thanks MSFT!" and "works just like the video shows!" - and then... and this is the most important part... Updating the software to not have the same flaws anymore!

    Is it true that like i thought, even now in 2014, still no one knows what is wrong or how to fix it? It doesn't seem that there is any evidence of progress with this...

    Monday, January 20, 2014 5:56 AM
  • HAHA! so at least for me. it looks like the pause/resume button is backwards... it would only download and proceed while paused. 
    Tuesday, January 21, 2014 7:29 PM
  • Hello Ladies and Gentlemen,

    You don't have to thank Microsoft for providing the wondering Operating System called "Windows" but don't disappoint them by showering your negative comments. Because they like your feedback directly and they act according to that. Please do understand, whatever problem you face in order to download the ISO from DreamSpark ELMS Webstore it has nothing to do with Microsoft or the DreamSpark website. It is your thoughts and Illusion since the download process is not affecting everyone but you. So please make sure that you are in a right platform and background to download your Software from ELMS Webstore. If you are having problems downloading please do specify yours with screenshots, so that it can be addressed individually.

    Thanks for the understanding.


    Wednesday, January 22, 2014 7:44 PM
  • Locking this thread, please see stickied post at the top of the forum.


    MSDN and TechNet Subscriptions Support <br/> Read the Subscriptions <a href="http://blogs.msdn.com/msdnsubscriptions">Blog! </a>

    Tuesday, January 28, 2014 3:58 AM