locked
Configuring IKEv2 VPN with Azure on Mac RRS feed

  • Question

  • I'm working on configuring IKEv2 VPN with Azure on Mac. So far I've been following these instructions to set up the P2S connection: https://docs.microsoft.com/en-us/azure/vpn-gateway/point-to-site-vpn-client-configuration-azure-cert. Here are the steps I've taken thus far:

    1. Created a Virtual Network
    2. Created a Virtual Network Gateway
    3. Configured a Point to Site Connection selecting an address pool to dynamically assign IPs to connected clients, and then created a self signed certificate on my Mac using the Certificate Assistant in the KeyChain application
    4. I exported that cert and converted it to a base64 cert using openssl: openssl x509 -inform der -in BenRudolph.cer -out BenRudolph.pem -sha1
    5. I then copied the base64 encoded cert and uploaded it to the VPN Gateway's Root Certificates.
    6. Then I downloaded the VPN client
    7. I then setup the IKEv2 VPN using the network settings on my Mac using the downloaded information (VPNServer node in the VPNSettings.xml.
    8. Then I set the Authentication settings, but it does not let me use the cert that was downloaded even though I installed it by double clicking. It only allows me to select the self signed cert that I created. When I try to authenticate, the authentication fails. 

    What am I missing here? Any help would be much appreciated. I have screenshots, but I can't submit them because it says my account is not verified.

    Thursday, February 8, 2018 7:15 PM

All replies

  • Just to clarify, which version of mac OS are using? 
    Note : IKEv2 VPN, a standards-based IPsec VPN solution. IKEv2 VPN can be used to connect from Mac devices (OSX versions 10.11 and above). 
    Reference: https://docs.microsoft.com/en-us/azure/vpn-gateway/point-to-site-about 
    Meanwhile you can post a reply here to get your account verified. So that you can post links and images -
    -------------------------------------------------------------------------------------------------------------
    Do click on "Mark as Answer" on the post that helps you and vote it as helpful, this can be beneficial to other community members
    Friday, February 9, 2018 9:56 AM
  • I'm using Mac OS 10.12.6. Here are some messages from the logs:

    Failed to find the VPN app for plugin type com.apple.neplugin.IKEv2

    Authentication method did not match

    Failed to process IKE Auth packet


    Friday, February 9, 2018 5:08 PM
  • The scenario can be best discussed as a support request. Because this needs a direct interaction to understand the requirements and to work on the possible solution. We recommend you to contact us by creating a technical support ticket - https://docs.microsoft.com/en-in/azure/azure-supportability/how-to-create-azure-support-request.
    -------------------------------------------------------------------------------------------------------------
    Do click on "Mark as Answer" on the post that helps you and vote it as helpful, this can be beneficial to other community members. 
    Saturday, February 10, 2018 5:56 PM
  • Follow this instruction to solve this issue.  Select the VPN client configuration files that correspond to the architecture of the Windows computer. Double-click the package to install it. On the client computer, navigate to Network Settings and click VPN.

    any issue related to printer click here 

    https://www.brotherprintersupportnumber.com/brother-customer-support/

    • Edited by ethan365 Wednesday, October 17, 2018 7:08 AM
    Wednesday, October 17, 2018 7:07 AM
  • Use the following steps to configure the native Windows VPN client for certificate authentication: Select the VPN client configuration files that correspond to the architecture of the Windows computer. Double-click the package to install it. On the client computer, navigate to Network Settings and click VPN.

    if anyone face printer issue click here https://www.brotherprintersupport247.com/blog/brother-printer-says-paper-jam-none/



    • Edited by ethan365 Tuesday, April 9, 2019 7:05 AM mistake
    Tuesday, April 9, 2019 7:04 AM