[Error] The iOS Designer MAC agent is not available RRS feed

  • Question

  • User294448 posted

    Today when I tried to start the Main.storyboard file of my project, I got this error:

    Previously I started this file many times without any problem.

    After getting this error, I also tried to start the storyboard file of the sample project Hello iOS, and it also failed with the same error.

    I have updated both Xamarin Visual Studio and Xamarin on Mac to their latest versions.

    Another detail: There was a warning in Xamarin log file: "There is a mismatch between the installed Xamarin.iOS (version 10.8) on and the local Xamarin.iOS (version While this may not be an issue, it might cause unexpected behaviors. When applying updates, make sure to keep both the Mac and Windows in sync." This is strange because both of them are up-to-date and still mismatch?

    Please help me to solve this problem. Thank you.

    FYI. Here is my system's configuration: - Windows 7 x64 SP1. - Visual Studio 2015. - Mac 10.12.

    Thursday, April 13, 2017 6:12 PM

All replies

  • User304575 posted

    Same here (version mismatch) - windows 10 x64 VS Community 2017 - Mac OSX Sierra in virtualbox

    Tuesday, April 18, 2017 1:00 PM
  • User125801 posted

    @sollano Have you tried working through our troubleshooting guide? It may help you as a first pass:


    @TobiasBeuving Please note that running macOS in a virtual machine on non-Apple hardware is against the EULA and as such is not a support configuration. If you do not have a mac, try looking at macincloud

    Tuesday, April 18, 2017 1:11 PM
  • User158279 posted

    Actually don't try MacInCloud its BAD. If you can get connected and stay connected long enough to set it up your lucky. If your unlucky they'll blame it on how they configured the server to start with then blame you for not being able to connect long enough to configure it correctly and then recommend you sub to a $1000 service called TeamViewer so that you can connect long enough to fix their setup.

    Best bet is just buy a mac mini or if your in the states just pick up an old mac desktop off eBay its cheaper in the long run.

    Thursday, April 20, 2017 2:18 AM
  • User294448 posted

    Hi all,

    After several days struggling with this problem, I have already found out the solution.

    This solution is not obvious, I don't know why it works, and it might be suitable for my specific case only.

    As I said above, initially my system worked well. This problem just appeared from nowhere, and I couldn't know why. I tried many things: - Update Xamarin on both Windows and Mac to their latest versions. - Remove and reinstall Xamarin. On both Windows and Mac. - Delete XMA caches. - Analyzing carefully Xamarin log files. - Tweak SSH config file on Mac. - ... But none of them worked.

    And then I suddenly remember that, at some point in time (after the moment my system still worked) I turned off the password log-in screen on my Mac for efficiency purpose. Today I just re-enabled this log-in screen, and everything worked again.

    This log-in screen seems to be irrelevant to the problem, that's why it takes so much time and effort from me to figure out the answer.

    I hope this answer will fix others's problem too.

    Monday, May 15, 2017 5:16 PM