none
Error in AS2 Encoder - special characters maybe conflicting with outbound delimiters RRS feed

  • Question


  • I've got an EDI file coming out of another system, and need to send it through BizTalk.  I setup the AS2 and tested that earlier with some other fake files.  Now I'm trying real files. 

    I'm dropping the file into a Flat File Receive Location with the pipeline: EDIReceive. 

    Then I get the following error in the Send Pipeline.  I think it's because there are colons and pound signs in these fields.

    The EDI delimiters on the incoming file are *]~ 
    and I set the same in the outgoing agreement . 

    The message context of the suspended message shows the correct agreement and parties. 

    There was a failure executing the send pipeline: "Microsoft.BizTalk.EdiInt.DefaultPipelines.AS2EdiSend, Microsoft.BizTalk.Edi.EdiIntPipelines, Version=3.0.1.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" Source: "AS2 encoder" Send Port: "sp_AS2_Generic_Http_Send_To_LinuxDev_2Way" URI: "http://as2.mycompany.com:12345/" Reason: Error: 1 (Field level error)
    SegmentID: MSG
    Position in TS: 9
    Data Element ID: MSG01
    Position in Segment: 1
    Data Value: 
    6: Invalid character in data element

    Error: 2 (Field level error)
    SegmentID: N1
    Position in TS: 10
    Data Element ID: N102
    Position in Segment: 2
    Data Value: 
    6: Invalid character in data element

    The following is the myCompany_otherCompany tab: 

    Thanks,
    Neal Walters 

    Wednesday, June 14, 2017 7:19 PM

Answers

  • It is my universal recommendation to keep the Fallback Settings disabled.

    Having that, the fundamental problem is nearly always Party Resolution.  "Fallback Settings for the x12 Protocol is in Disabled state." means Party Resolution failed.

    The Context maybe be showing the Agreement resolved during Receive which you indicate worked.  So, it is still Send resolution that is not working.

    • Marked as answer by Neal Walters Thursday, June 15, 2017 4:18 PM
    Thursday, June 15, 2017 3:29 PM

All replies

  • Are the Fallback Settings disabled?

    The invalid character could also be leading or trailing spaces.

    Wednesday, June 14, 2017 8:48 PM
  • I just disabled fallback, and now get this: 

    There was a failure executing the send pipeline: "Microsoft.BizTalk.EdiInt.DefaultPipelines.AS2EdiSend, Microsoft.BizTalk.Edi.EdiIntPipelines, Version=3.0.1.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" Source: "EDI Assembler" Send Port: "sp_AS2_Generic_Http_Send_To_LinuxDev_2Way" URI: "http://as2.mycompany.com:12345/" Reason: Fallback Settings for the x12 Protocol is in Disabled state.  

    So this tells me what? Somehow the Receive Port matching the agreement, but the SendPort isn't? 

    I changed the Fallback Settings ISA16 from : to ] and the file seems to be going through. 

    How do I make sure though that it uses the agreement and not the fallback? 
    I mentioned in my original question "The message context of the suspended message shows the correct agreement and parties. "

    Thanks,

    Neal 

    Thursday, June 15, 2017 2:43 PM
  • It is my universal recommendation to keep the Fallback Settings disabled.

    Having that, the fundamental problem is nearly always Party Resolution.  "Fallback Settings for the x12 Protocol is in Disabled state." means Party Resolution failed.

    The Context maybe be showing the Agreement resolved during Receive which you indicate worked.  So, it is still Send resolution that is not working.

    • Marked as answer by Neal Walters Thursday, June 15, 2017 4:18 PM
    Thursday, June 15, 2017 3:29 PM
  • Okay, I think I got it.  I didn't have the SendPorts set in the agreement.  So that's obviously part of the matching algorithm. 

    I appreciate the help and ideas! 

    Neal 

    Thursday, June 15, 2017 4:17 PM