locked
Relative URL in SSRS for SharePoint Navigation RRS feed

  • Question

  • Hi,

    I have SSRS installed in SharePoint integrated mode (SP & SSRS are on different machines). Once the report is hosted on the SP page, I need to Navigate to a differnt SharePoint page by clicking on the existing report.

    Problem

    1. Although the relative URL works. I get the below warning message asking for absolute URL

    2. Our SharePoint site is hosted on internet by using TMG. So although the relative path works in intranet, but when on Internet the URL tries to navigate to the intranet site.

    Is their something that I am missing here?

    Thanks,

    Kalyan

    Wednesday, July 11, 2012 3:33 AM

Answers

  • Hi There

    Thanks for your posting. The file:// https etc protocol should work, however it may be not a default protocol. That is why the warning happens.

    For more details please see

    http://social.msdn.microsoft.com/Forums/en-US/sqlreportingservices/thread/926b50ae-3062-4e32-83b4-fd2dcef0ac58/

    many thanks

    Syed Qazafi Anjum

    • Proposed as answer by Mike Yin Tuesday, July 17, 2012 7:45 AM
    • Marked as answer by Mike Yin Wednesday, July 18, 2012 10:53 AM
    Wednesday, July 11, 2012 4:52 AM
  • You need to ensure that you have correctly set up the alternate access mappings so that any link placed on a page by SSRS will be translated by SharePoint to the correct version required for the user.  Often when using TMG, administrators try to let TMG do all the link translation which is not enough for SharePoint.

    Check your AAMs from Central Admin -> System

    Assuming your internal address is http://intranet and the external address id http://website.company.com, you need to create a Public URL of http://website.company.com in one zone and a URL of http://intranet in another zone.

    If your TMG server is also doing SSL offloading, you will need to create a public URL for https://website.company.com (instead of the one for http://website.company.com) add an Internal URL of http://website.company.com.

    Duncan


    Duncan Sutcliffe
    All postings are solely my own and do not represent or constitute Hitachi Consulting's positions, views, strategies or opinions.

    • Proposed as answer by Mike Yin Tuesday, July 17, 2012 7:45 AM
    • Marked as answer by Mike Yin Wednesday, July 18, 2012 10:53 AM
    Wednesday, July 11, 2012 7:40 AM

All replies

  • Hi There

    Thanks for your posting. The file:// https etc protocol should work, however it may be not a default protocol. That is why the warning happens.

    For more details please see

    http://social.msdn.microsoft.com/Forums/en-US/sqlreportingservices/thread/926b50ae-3062-4e32-83b4-fd2dcef0ac58/

    many thanks

    Syed Qazafi Anjum

    • Proposed as answer by Mike Yin Tuesday, July 17, 2012 7:45 AM
    • Marked as answer by Mike Yin Wednesday, July 18, 2012 10:53 AM
    Wednesday, July 11, 2012 4:52 AM
  • Thanks for the reply. Even if I ignore the warning, can you tell me about point 2 that I have mentioned?

    Thanks,

    Kalyan

    Wednesday, July 11, 2012 5:26 AM
  • You need to ensure that you have correctly set up the alternate access mappings so that any link placed on a page by SSRS will be translated by SharePoint to the correct version required for the user.  Often when using TMG, administrators try to let TMG do all the link translation which is not enough for SharePoint.

    Check your AAMs from Central Admin -> System

    Assuming your internal address is http://intranet and the external address id http://website.company.com, you need to create a Public URL of http://website.company.com in one zone and a URL of http://intranet in another zone.

    If your TMG server is also doing SSL offloading, you will need to create a public URL for https://website.company.com (instead of the one for http://website.company.com) add an Internal URL of http://website.company.com.

    Duncan


    Duncan Sutcliffe
    All postings are solely my own and do not represent or constitute Hitachi Consulting's positions, views, strategies or opinions.

    • Proposed as answer by Mike Yin Tuesday, July 17, 2012 7:45 AM
    • Marked as answer by Mike Yin Wednesday, July 18, 2012 10:53 AM
    Wednesday, July 11, 2012 7:40 AM
  • Sorry for the late reply...Duncan, yes the problem was with AAM settings & Extending the webapplication...but had to raise a ticket with MS to find the exact problem :(
    Thursday, September 20, 2012 8:37 PM