none
Error attempting to create or edit publish profiles

    Question

  • I am unable to create or edit publish profiles.  I receive the following error in any project i attempt to do so.

    Since i can't upload pictures, text follows: 

    Microsoft Visual Studio 

    Method not found: 'Newtonsoft.Json.Linq.JObject Microsoft.VisualStudio.ProjectSystem.DotNet.Helpers.JsonHelper.ParseJsonContent(System.String)'.

    Saturday, July 16, 2016 4:28 AM

Answers

  • Hi,

    Could you please tell me what's the version of your Visual Studio and what's your project type? Did you publish a .Net Core web application?

    How about creating a new ASP.NET Web applicaiton and publish it?

    Please try running your Visual Studio in Safe mode to Check whether some add-ins and extensions affect it (devenv /safemode)

    If the error occured for a new created web application. I suppose there might be something wrong with your Visual Studio. Try to repair it or install the VS2015 Update3, the latest update of VS2015.

    Best Regards,

    Lake Xiao

    Saturday, July 16, 2016 11:35 AM
    Moderator

All replies

  • I am facing the same error while publishing a dot net core web api to azure

    Charul Pant

    Saturday, July 16, 2016 9:05 AM
  • Hi,

    Could you please tell me what's the version of your Visual Studio and what's your project type? Did you publish a .Net Core web application?

    How about creating a new ASP.NET Web applicaiton and publish it?

    Please try running your Visual Studio in Safe mode to Check whether some add-ins and extensions affect it (devenv /safemode)

    If the error occured for a new created web application. I suppose there might be something wrong with your Visual Studio. Try to repair it or install the VS2015 Update3, the latest update of VS2015.

    Best Regards,

    Lake Xiao

    Saturday, July 16, 2016 11:35 AM
    Moderator
  • I have the exact same error as "ghostofrecon.net". I tried starting VS 2015 U3 in safemode and doing the publish and it worked.

    Without the safe mode, when I click in the main menu -> Build -> Publish, I get the above error. When I click in Solution Explorer on the project -> Publish, nothing happens.

    If it works in safemode, how can I figure out what exactly is causing the problem?

    Friday, July 22, 2016 1:39 PM
  • Hi,

    >>I tried starting VS 2015 U3 in safemode and doing the publish and it worked.

    If it works well in safe mode. I think there would be some extensions or add-ins. Please check whether you have installed the extensions or some add-ins. Uninstall these extensions and add-ins. 

    By the way, since it works well in safe mode. I suggest you'd better use your Visual Studio in safe mode.

    Best Regards,

    Lake Xiao

    Monday, July 25, 2016 1:07 AM
    Moderator