none
Admin account blocked after syspreping WES-7 RRS feed

  • General discussion

  • Hi Guys,
    I need a bit of advise. I've got a WES-7 based system which I must sysprep so I could distribute clones to more PCs. I've created an answer file to make the sysprep process fully automatic. Everything looks fine until it is coming to auto log in to windows desktop. For some reason the password doesn't match to the login. Any ideas are very welcome


    WES-7 (x64)
    /generalize /oobe /shutdown /unattend:unattend.xml

    The files are 64bit versions of course.



    ---------unattend.xml--------------
    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:ew="urn:schemas-microsoft-com:embedded.unattend.internal.v1">
        <servicing>
           <package action="configure">
              <assemblyIdentity name="Microsoft-Windows-EmbeddedEdition" version="6.1.7601.17514" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" />
              <ewackageInfo releaseType="Product" customInfoVersion="1.0" />
           </package>
        </servicing>
        <settings pass="generalize">
           <component name="Microsoft-Windows-PnpSysprep" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
              <PersistAllDeviceInstalls>true</PersistAllDeviceInstalls>
           </component>
        </settings>
        <settings pass="specialize">
           <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
              <TimeZone>GMT Standard Time</TimeZone>
              <ProductKey>here should be licence key</ProductKey>
           </component>
        </settings>
        <settings pass="oobeSystem">
           <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
              <AutoLogon>
                 <Password>
                    <Value>Admin_account</Value>
                    <PlainText>true</PlainText>
                 </Password>
                 <Username>password</Username>
                 <Enabled>true</Enabled>
              </AutoLogon>
              <OOBE>
                 <NetworkLocation>Work</NetworkLocation>
                 <SkipUserOOBE>true</SkipUserOOBE>
                 <SkipMachineOOBE>true</SkipMachineOOBE>
                 <ProtectYourPC>3</ProtectYourPC>
                 <HideEULAPage>true</HideEULAPage>
              </OOBE>
           </component>
        </settings>
        <ew:answerFileInfo distributionSharePath="C:\Program Files (x86)\Windows Embedded Standard 7\DS64\DS" footprint="875560960" ecoreFootprint="875560960" />
    </unattend>
    • Edited by Marcino78 Tuesday, August 21, 2012 3:38 PM
    Tuesday, August 21, 2012 3:25 PM

All replies

  • Username = password

    Password = Admin_account

    Might you have meant

    Username = Admin_account

    Password = password

    ?


    "Learning without thought is labor lost; Thought without learning is perilous." Confucius

    Tuesday, August 21, 2012 4:19 PM
  • Yeaa, but that doesn't matter as I did change those two for the forum purpose. Thanks.

    Wednesday, August 22, 2012 8:00 AM
  • I am not sure what you changed for the forum post: <Username>password</Username> doesn't make sense.

    Did you use ICE to create sysprep unattended file?

    -Sean


    www.sjjmicro.com / www.seanliming.com / www.annabooks.com, Book Author - Pro Guide to WES 7, XP Embedded Advanced, Pro Guide to POS for .NET

    Wednesday, August 22, 2012 4:15 PM
    Moderator
  • Checking with my answer file.

    I don't have a password on my administrator account, so after the final sysprep, it logs in as the AutoLogon User it created and Adminstrator is inaccessible.

    You can test if you have a password on administrator fairly easily in Audit mode, try switching to another user, if you can't get back to administrator, no password ^^; (I did this the hard way ^^!)


    =^x^=

    Thursday, August 23, 2012 6:58 AM
  • I am not sure what you changed for the forum post: <Username>password</Username> doesn't make sense.

    Originally there were my customer’s Username & Password, so obviously I couldn’t post it here.

    Also I've just accidently swapped them over while changing them.

    Did you use ICE to create sysprep unattended file?

    Yes, in the first place. But later it was modified outside of ICE.

    • Edited by Marcino78 Thursday, August 23, 2012 8:24 AM
    Thursday, August 23, 2012 7:53 AM
  • Checking with my answer file.

    I don't have a password on my administrator account, so after the final sysprep, it logs in as the AutoLogon User it created and Adminstrator is inaccessible.

    You can test if you have a password on administrator fairly easily in Audit mode, try switching to another user, if you can't get back to administrator, no password ^^; (I did this the hard way ^^!)


    =^x^=

    That is a whole idea - to not change the username and password which had been given to my customer. Besides entire software loaded and configured in to the system are using  that username and it can't be changed.

    Essentially, I've found the way how to fix it. I've created another user before sysprep, then sysprep it, and after first boot I've logged in as a second user, reset the password of the first (main) user, restarted the system, logged in as the first main user, removed the second user and finally set the autologin up. Everything worked fine. But there one issue - a quantity. The pre-configured image is going to be applied to 100-200 units and there is no way the procedure will be repeated every single time. I need better way, a quick way, a fully automated way.

    Thursday, August 23, 2012 8:42 AM