locked
adding c# project dll to gac without visual studio(gacutil) RRS feed

  • Question

  • Orchestration project calls a method of c# library project. I tried to include the c# project dll in the itemgroup, but the btdf is failing saying the dll is missing. So I have created a setup project with the primary output taking the c# project, so it created a msi and I ran that first then followed by btdf. the deployment then worked without errors. This however, resulted in an issue. The component dll is not added to gac, so orchestration is not calling the c# method as part of the orchestration. I do not see the dll in the gac(c:/windows/assembly). I do not have visual studio installed so could not use the gacutil. Is there anyway I can add to the gac. running the msi should add but not seen in the c:/windows/assembly.

    Is there anyway I can add to gac?

    Thursday, May 22, 2014 8:54 PM

Answers

  • Orchestration project calls a method of c# library project. I tried to include the c# project dll in the itemgroup, but the btdf is failing saying the dll is missing. 

    Can you paste here your Itemgroup?

    You need to add it like below:

    <ItemGroup>

     <Components Include="yourC#projectname.dll">

       <LocationPath>..\yourC#projectname\bin\$(Configuration)</LocationPath>

     </Components>

    </ItemGroup>

    I am copying my answer from my previous thread. Did you try that?

    old thread




    Friday, May 23, 2014 11:11 AM

All replies

  • If you are using BizTalk Server 2010 or above (.NET Framework 4.0 or above), the GAC is located in

    C:\Windows\Microsoft.NET\assembly\GAC_MSIL

    and not the path you are referring to.

    If you install the .MSI (not import but install) then any DLL's both BizTalk- and Non-BizTalk DLL's should be added to the GAC as long as the checkbox "Add to the global assembly cache on MSI file install" is checked.

    Morten la Cour

    Thursday, May 22, 2014 9:34 PM
  • Orchestration project calls a method of c# library project. I tried to include the c# project dll in the itemgroup, but the btdf is failing saying the dll is missing. 

    Can you paste here your Itemgroup?

    You need to add it like below:

    <ItemGroup>

     <Components Include="yourC#projectname.dll">

       <LocationPath>..\yourC#projectname\bin\$(Configuration)</LocationPath>

     </Components>

    </ItemGroup>

    I am copying my answer from my previous thread. Did you try that?

    old thread




    Friday, May 23, 2014 11:11 AM