none
trying to test helloWorld WCF (on win7 pro VS2012 pro) -- error says directory browsing not allowed -- how to enable? RRS feed

  • Question

  • I am working on a sample HelloWorld wcf project but cannot test it -- not getting a directory listing when I F5 it.  I get a Directory Browsing error. How can I enable directory browsing? I already went to my IIS (win7 pro) and enabled directory browsing, but that didn't get it. I also went to the web.config file in my wcf project and  tried

    <configuration>

        <system.web>
          <compilation debug="true" targetFramework="4.5" />
          <httpRuntime targetFramework="4.5" />
          <directoryBrowse enabled="true">          <<<----------I tried this but got Debug Error
        </system.web>

    </configuration>

    Here's a picture of the error message I get -- how to fix?


    Rich P

    Thursday, July 16, 2015 4:53 PM

All replies

  • I actually fixed this myself.  I went to the command prompt and CD'd to

    C:\Program Files\IIS Express

    once there I typed in this command and hit enter

    appcmd set config /section:directoryBrowse /enabled:true

    this command applied directoryBrowsing to true.  Now I get a listing when I press F5 and can resume my testing


    Rich P

    Thursday, July 16, 2015 5:17 PM