locked
Target framework 3.5 vs. 4.0 RRS feed

  • Question

  •  

    Hello,

    I have to use Crystal Reports in my VB solution, so I downloaded the free CR for VS 2010. I watched a video on youtube about how to get started with CR using VS 2010. In the video, he said you have to set the target framework to 4.0 standard for the CR Report Viewer to show up in the toolbox. When I started a new solution, I selected Target Framework 4.0, and the viewer did not show up. I started another solution, and selected framework 3.5, and the viewer showed up in the toolbox. Will I loose anything if I use 3.5 for the framework instead of 4.0? The solution that I need CR for uses SQLServerCE with ADO.NET. If I can use 3.5, how can I change the solution to Target Framework 3.5? I searched the whole solution for TargetFramework, and there are no occurrences. There is no Target Framework selection box in the compile tab of the project properties.

    Thanks,

    Ralph65

    Saturday, January 5, 2013 3:05 AM

Answers

  • Ralph,

    It is difficult to find in version 2010 therefore is replaced in version 2012.

    It is under Advance compile Options in 2010 I thought it was:

    Project -> Application properties -> Compile options -> Advance Compile options 


    Success
    Cor

    • Proposed as answer by Mr. Monkeyboy Saturday, January 5, 2013 10:44 AM
    Saturday, January 5, 2013 10:39 AM
  • You're describing a problem caused by VS2010 creating 4.0 client default projects.

    Change the 4.0 client to 4.0.

    Saturday, January 5, 2013 8:16 AM
  • Hi, Cor,

    I found it, set it to Net 4.0, not Net 4.0 Client Profile, and the Crystal Reports controls showed up in the toolbox!

    Thank you so much!

    Ralph

    • Marked as answer by Mike Feng Monday, January 7, 2013 11:06 AM
    Saturday, January 5, 2013 9:04 PM

All replies

  • Did you verify that you are selecting framework 4.0 full and not client?

    http://www.sdn.sap.com/notes?id=0001606621&boj=/sap/bc/bsp/spn/scn_bosap/notes.do?access=69765F6D6F64653D3939382669765F7361706E6F7465735F6E756D6265723D30303031363036363231


    You've taught me everything I know but not everything you know.

    Saturday, January 5, 2013 3:13 AM
  • To target net framework 3.5 I believe you go into Project -> application properties -> Application and set Target Framework: to the appropriate value.

    However I have no idea what if anything you may lose by doing so.


    You've taught me everything I know but not everything you know.

    Saturday, January 5, 2013 3:42 AM
  • Hellp,

    Under Project, there is only <project name> properties. (ie. Report Test Properties) If I click on that, I get the screen with Application Properties. Nowhere on that tab is a place to set the target framework.

    When I start a new solution, in the target framework drop down box, I have .NET framework 2.0, 3.0, 3.5, and 4.0. On the 4.0, it does not say full or client.

    Thanks,

    Ralph

    Saturday, January 5, 2013 5:39 AM
  • You're describing a problem caused by VS2010 creating 4.0 client default projects.

    Change the 4.0 client to 4.0.

    Saturday, January 5, 2013 8:16 AM
  • Ralph,

    It is difficult to find in version 2010 therefore is replaced in version 2012.

    It is under Advance compile Options in 2010 I thought it was:

    Project -> Application properties -> Compile options -> Advance Compile options 


    Success
    Cor

    • Proposed as answer by Mr. Monkeyboy Saturday, January 5, 2013 10:44 AM
    Saturday, January 5, 2013 10:39 AM
  • Hi, Cor,

    I found it, set it to Net 4.0, not Net 4.0 Client Profile, and the Crystal Reports controls showed up in the toolbox!

    Thank you so much!

    Ralph

    • Marked as answer by Mike Feng Monday, January 7, 2013 11:06 AM
    Saturday, January 5, 2013 9:04 PM