locked
Help with physicshelper RRS feed

  • Question

  • I installed the physicsHelper (  http://physicshelper.codeplex.com/releases/view/74385 ), and I referenced the .dll's to my project. I still get nothing in the assets>behaviors of the project though. I've tried building/restarting the project. Idk what else to do. The installation claims to have installed successfully, but it doesnt work. Thanks for any help.
    Monday, June 18, 2012 1:55 AM

Answers

All replies

  • I suggest asking for assistance in the Discussions area of the PhysicsHelper site: http://physicshelper.codeplex.com/discussions.

    Monday, June 18, 2012 12:42 PM
  • What type of project are you creating? Are you referencing the correct set of assemblies for your target platform (SL or WP7)?  Did you close Blend and re-open it after installing the msi?
    Monday, June 18, 2012 2:31 PM
    Moderator
  • Thanks for the reply. I'm pretty sure im using assemblies from the correct libraies because the folders are nicely named, "Silverlight4" and "WP7.1". Although, out of desperation, I tried stuff out of the silverlight4 folder. I closed and re-opened blend and even uninstalled/reinstalled the msi. After installing the msi,  I right click the references folder>select add reference>browse to the 'physics helper lib' folder>select "Farseer Physics 3.0 WinPhone.DLL" >click Open.

    I notice it is added to the references folder then I restart blend. But still no physics behaviors under the assets panel.  I've uncollapsed everything just incase. After that failed, I went through adding each .dll 1 by 1. Out of it all, I was able to get 1 physics behavior. It is the "Spritehand.PhysicsBehaviors.dll". It creats a single behavior called "ucExplode". I know there should be about a dozen behaviors, so this is also a fail  : (

    What am I doing wrong?

    Monday, June 18, 2012 3:15 PM
  • You didn't answer what type of project you are trying to create? What platform, version and language?
    Monday, June 18, 2012 3:29 PM
    Moderator
  • Oh, it's a Windows Phone 7 project, with C#. It doesnt say it, but I believe this is .NET 4.0.

    I even created a new project just to see if I could get this to work.

    Monday, June 18, 2012 6:48 PM
  • Version for WP7 would either be 7.0 or 7.1 (Mango). The main download on that page is for 7.1 (Mango). 


    Monday, June 18, 2012 6:50 PM
    Moderator
  • Thanks for the reply

    Hmm... How can I change/build a project in 7.1? How can I tell if im in one that is either? Maybe all my projects are being built in 7.0? All I click is New Project> select windows phone application> the language> name. That's it. no signs of 7.0 or 7.1 to my knowledge.


    Monday, June 18, 2012 7:09 PM
  • What version of Blend are you using? You can see this in help -> about

    If it is 4.0.30816.0 you are using the version that can create WP7.1 projects, if it is 4.0.20901.0 (that might not be exactly correct) it is the version that can only do WP7.0 projects. 

    If you don't have the newer version, you would need to install the WP7.1 tools.

    As far as converting it, I believe you can do that in VS by opening the properties for the project and changing the Target Windows Phone OS Version drop down.

    Monday, June 18, 2012 7:13 PM
    Moderator
  • Thanks.

    In fact, I am using a 4.0.2 ver. I must find the WP7.1 tools! Thanks for all the help. I'll let you know if this works shortly.

    Monday, June 18, 2012 7:19 PM
  • This should be the main download page:

    http://create.msdn.com/en-us/home/getting_started

    You want to get the Windows Phone 7.5 tools (7.5 == 7.1)

    • Marked as answer by Classic Run Monday, June 18, 2012 8:18 PM
    Monday, June 18, 2012 7:20 PM
    Moderator
  • I believe this to be the download page for those updates/tools  ( http://create.msdn.com/en-us/resources/downloads ).

    Incase anyone else makes this mistake. Thanks again, this was the mistake I was making Chuck : ) 


    Monday, June 18, 2012 7:24 PM