locked
Device Emulator with Windows 7 RRS feed

  • Question

  • Hi everybody,

    since I've upgraded from XP (x86) to Windows 7 Ultimate (x64) I don't seem to be able to use the device emulator any more. When opening a smartphone project (or creating a new one) and starting the emulator from within Visual Studio 2008 it just opens the window and says "restoring previous state". It doesn't really seem to load the os image.

    Anybody got an idea what I could try?

    By the way, that's my version:
    Microsoft Device Emulator, Version 3
    9.0.21022.8
    Monday, January 4, 2010 5:26 PM

All replies

  • I've not much idea what you could try other than clearing all the states, and if that does not help reinstalling VS. Other than that I can only offer you this: I'm using the emulators on several Win7 x64 workstations without any problems whatsoever, so it does generally work.
    Wednesday, January 6, 2010 2:57 AM
  • >>"since I've upgraded from XP (x86) to Windows 7 Ultimate (x64) I don't seem to ...

    What did you mean by "upgraded"? As I know there is no direct upgrade form Windows XP to Windows 7. You have to reinstall every program. Maybe you meant XP -> Vista > Windows 7 but I don't feel like it.

    Recently I did a clean installation of Windows 7 x64 followed by the installation of Visual Studio 2008 and SP1. It works fine for me. You may also try running VS2008 as administrator (right click on the VS2008's shortcut and then select "Run as administrator).


    Please mark the post that helps you, and unmark that does not. This benefits our community.
    Thursday, January 7, 2010 8:46 AM
    Moderator
  • By upgrade I meant a clean reinstallation. The only thing that might not be perfectly clean: I'm in a domain environment with roaming profiles. As the profile directory format is different I manually moved some folders in the Application Data folder to the new AppData Folder. But I don't remember doing that with the Microsoft folder.

    The emulator's interface doesn't really do anything when I click menu options. Neither does it respond to exit, clear states of anything else.
    I went to C:\Users\%username%\AppData\Roaming\Microsoft\Device Emulator and deleted the single file that was in there (~45 MB). But still no change.

    Everytime I start up the emulator, it's trying to load some state. That even happens when I choose another OS from within Visual Studio.

    Does anything know where the emulator save its states? I mean where I saves that there are states at all, some kind of configuration file.
    Saturday, January 9, 2010 10:06 AM
  • The first thing I could think of is a permission issue. Have you tried what I've said in my previous post - "You may also try running VS2008 as administrator (right click on the VS2008's shortcut and then select "Run as administrator)."

    The saved states are in the following folder:
    C:\Users\[User Name]\AppData\Roaming\Microsoft\Device Emulator
    You can delete them (.dess files) and try again.
    Please mark the post that helps you, and unmark that does not. This benefits our community.
    Monday, January 11, 2010 3:38 AM
    Moderator
  • Yes, tried to run it as admin, but forgot to mention it. As well as deleting the saved state file. The folder is completely empty, but the emulator is still bringing up the message it was trying to load a state. I wonder which one. There are none!
    Tuesday, January 12, 2010 5:00 PM
  • Do you have the same problem with the local "Administrator" account?

    You can also try:
     1. Make sure you install VS2008 SP1.
     2. Install Windows Mobile 6 SDK Refresh.
     3. Run the command "devenv.exe /resetuserdata". Be aware this will clear all user data and settings as its name suggests. 
     4. Delete the following folder "C:\Users\[User Name]\AppData\Local\Microsoft\CoreCon\1.0".
     
    Please mark the post that helps you, and unmark that does not. This benefits our community.
    Wednesday, January 13, 2010 6:18 AM
    Moderator
  • From what you're writing it's not clear to me if you've already trie to clear the saved states by using the "Device Emulator Manager"... ("[...] and starting the emulator from within Visual Studio 2008 ") I mean "C:\Program Files (x86)\Microsoft Device Emulator\1.0\dvcemumanager.exe". As a test, pls run it (Run as Admin), then right-click on one of those emulators that you're having problem with and select "Clear Saved State": it'll delete the .dess file that you may have imported from the roaming profile (this is just an idea, didn't check if that was possible).

    HTH!
    Thanks,
    ~raffaele
    http://blogs.msdn.com/raffael

    This posting is provided 'as is' with no warranties and confers no rights.
    Wednesday, January 13, 2010 9:05 PM
  • Hi everybody,

    thank you all for the proposals. Unfortunately none of them has helped so far.

    1. I have made sure to install SP1
    2. Windows Mobile 6 SDK Refresh as well as SDK 6.5 are installed.
    3. I did reset my user data.
    4. I did delete the whole directory
    5. I did use dvcemumanager.exe and deleted the states of ALL OS's.

    I even created a new local user and ran Visual Studio via it. That damn emulator is still trying to load some state. I just don't understand this!
    Saturday, January 16, 2010 5:47 PM
  • Hi Jens, a possible troubleshoothing hint, considering that you wrote:
    > The only thing that might not be perfectly clean: I'm in a domain environment with roaming profiles. As the profile directory format is different I manually moved some folders in the Application Data folder to the new AppData Folder. But I don't remember doing that with the Microsoft folder.

    I sincerely don't know if moving folders that way can be recommended, however pls consider that when Device Emulator saves a state, a .DESS file is created. I don't remember on pre-Windows 7 _where_ it was created, anyway through Process Monitor I could see that for Windows 7 it's precisely under "%userprofile%\AppData\Roaming\Microsoft\Device Emulator". Do you think you can revert your changes on the AppData folder, at least for testing purposes? Otherwise, you can for example use Process Monitor to see where the Device Emulator is trying to take the .dess file.

    HTH!
    Thanks,
    ~raffaele
    http://blogs.msdn.com/raffael

    This posting is provided 'as is' with no warranties and confers no rights.
    Monday, January 18, 2010 1:26 PM
  • Hi Raffaele,

    Process Monitor was a good idea. There were a bunch of dess-files under C:\ProgramData\Microsoft\Device Emulator

    I've deleted all of them.

    It's still looking for something and not showing any picture. When the emulator windows gets to the front it's just displaying what the window behind is. In other words it's not drawing its own display area.

    That's what ProcessMon is telling me. Doesn't seem to actually find any dess-file:

    22:08:11,2767078    devenv.exe    4444    QueryDirectory    C:\Users\jens\AppData\Roaming\Microsoft\Device Emulator\*.dess    NO SUCH FILE    Filter: *.dess

    22:08:11,3997113    DeviceEmulator.exe    5108    CreateFile    C:\Users\jens\AppData\Roaming\Microsoft\Device Emulator\{E4FC2BC5-3AC4-452C-A893-AD4F273C3A7C}.dess    NAME NOT FOUND    Desired Access: Generic Read, Disposition: Open, Options: Synchronous IO Non-Alert, Non-Directory File, Attributes: N, ShareMode: Read, AllocationSize: n/a

    22:08:11,4040242    DeviceEmulator.exe    5108    CreateFile    C:\ProgramData\Microsoft\Device Emulator\{E4FC2BC5-3AC4-452C-A893-AD4F273C3A7C}.dess    NAME NOT FOUND    Desired Access: Generic Read, Disposition: Open, Options: Synchronous IO Non-Alert, Non-Directory File, Attributes: N, ShareMode: Read, AllocationSize: n/a
    Friday, January 22, 2010 9:53 PM