locked
TF255275: The following Web service for SQL Server Reporting Services could not be accessed: http://ServerName/ReportServer/ReportService2005.asmx RRS feed

  • Question

  • HI!

    I am getting the following error while configuring Reporting services in TFS.
    TF255275: The following Web service for SQL Server Reporting Services could not be accessed: http://ServerName/ReportServer/ReportService2005.asmx.

    I selected "NativeMode" during the ReportServer Configuration.
    Still i am getting the error. I tried to delete the database and configured again, but the problem not solved.
    I installed SQLserver 2008, Sharepoint and TFS 2010 all on same system.

    DuringSQL Server installation for Reporting Services ,i selected "Sharepoint Integration Mode".
    Can any one suggtest me the possiblesolution to resolve this.
    Thanks & regards,
    Sekhar
    Thursday, March 11, 2010 2:37 PM

Answers

All replies

  • Hi,

    When you deleted the reporting database and reconfigured reporting services, did you choose Native or Integrated?  I received this error when I had it configured in integrated mode and then it was fixed after I reconfigured it in native.

    According to this post, it recommends deleting the reporting databases from the file server too.
    http://blogs.msdn.com/habibh/archive/2009/07/06/troubleshooting-team-foundation-server-2010-beta-1-error-tf255275.aspx

    Have you tried this?

    I hope it helps,
    Mike


    blog - http://www.codesmartnothard.com
    Friday, March 12, 2010 4:13 AM
  • HI!

    Mike,

    I selected "Native" during ReportServer Configuration, but still the error is displaying.

    I already tried the steps mentioned in the post..

    During SQL Reporting services installation "Integrated" was selected, is this may be a cause?

    Suggest me,

    Sekhar

     

     

     

    Friday, March 12, 2010 4:43 AM
  • Sekhar,

    I don't think the original configuration setting matters.  Rerunning the configuration should overwrite it.  I found this post where SSRS was stopped and it gave this  message. 

    http://www.jeffreyhunsaker.com/2010/02/tfs-2010-upgrade-from-beta2-to-rc.html

    I'm going to install TFS 2010 on a new server tonight or tomorrow.  I'll let you if I come across the error. 

    Are you installing TFS 2010 RC?

    Mike
    blog - http://www.codesmartnothard.com
    Saturday, March 13, 2010 2:09 AM
  • Sekhar,

    I installed SharePoint 2010 on a server and installed Reporting Services in Integrated mode.  I then decided to install TFS 2010 RC on it so I changed SSRS back to Native mode.  I didn't run into any problems or that error.  I wish I could be more help.  Is it an option to reimage the server and reinstall everything?

    Mike
    blog - http://www.codesmartnothard.com
    Tuesday, March 16, 2010 2:52 AM
  • HI!

    Mike,

    I reinstalled  SQLServer2008 and re configured sharepoint and every thing.

    Now, i did n't got this problem during TFS configuration wizard.

    Thanks you all...

    Thanks for your help.

    Sekhar

     

    Friday, March 19, 2010 3:51 AM
  • Mike,

    This worked, that you for your help. I got this issue in TFS advanced configuration wizard.  But I am not sure this going to cause any issue on sharepoint integration yet.

    Shine


    Shine
    Sunday, April 18, 2010 6:10 PM
  • Shine,

    I'm glad that helped.  What do you by you are not sure if that is going to cause any issue on SharePoint integration?  Here's a list of features suppported by using SharePoint Integrated mode that won't be available anymore. It basically turns SharePoint into a SSRS writer.  If you are not trying to do one of these features, you should be fine.

    http://technet.microsoft.com/en-us/library/bb326290.aspx

    Thanks,

    Mike


    blog - http://www.codesmartnothard.com
    Monday, April 19, 2010 2:17 AM
  • Greetings...

    How is this not a Catch-22? I want SQL Server 2008 R2 Reporting Services integrated with SharePoint Server 2010, but Team Foundation Server 2010 Readiness Checks (Advanced Configuration Wizard) won't allow me to continue with configuration because the Report Server is configured to run in SharePoint integration mode?

    Connecting to the report server from SQL Server Management Studio seems to suggest an alternate way to connect: "You specified a report server that runs in SharePoint integrated mode. To access full functionality in SQL Server Management Studio it is recommended that you connect to a sharepoint web site that this report server is integrated with. Would you like to change Server Name to specify SharePoint Web site?"

    I find this totally show stopper baffling at this point.

    Friday, May 21, 2010 4:52 AM
  • Let me approach this from another direction:

    Why would TFS 2010 care whether my SQL Server 2008 R2 is tightly integrated with Sharepointe Server 2010 or not? Why would tight integration be considered bad for TFS and a show stopper to further configuration?

    Friday, May 21, 2010 2:49 PM
  • Hi,

    Great questions.  I found this link that outlines the differences.  To me, I didn't see any show stoppers.  It seems like it adds more than takes away.  It might be the way TFS displays the lists of reports in Team Explorer.  Since the report manager is not available in integrated mode, maybe it also prevents this.

    http://msdn.microsoft.com/en-us/library/bb326290.aspx

    I also found another cause/fix for this issue.  I ran into this error when I renamed the server after SQL Server was installed (and SSRS was configured) but before I installed and configured TFS 2010.  I am doing a non-domain install so I am using local accounts.  I deleted the windows user login from the database, deleted the user from the reportserver and reportservertempdb.  I recreated the user with the new server name.  I granted roles: public and RSExecRole to the ReportServer and ReportTempDB databases.  Lastly I noticed that the SSRS configuration was still pointing to the old server name and I wasn't able to hit the report server URL.  I went to the database setting and chose the option to change the connection to an existing database.  I changed it to the new server name and it worked fine after that.

    I hope that helps,

    Mike


    blog - http://www.codesmartnothard.com
    Sunday, July 4, 2010 4:15 AM
  • I too just hit this issue and the workaround described (deleting /recreating report server databases) fixed the problem. In my case, I had created a VM with SQL Server 2008 R2 installed, ran sysprep on it, backed it up so I could use it as a template and then installed SP/TFS on a server based on this template...
    Monday, July 5, 2010 3:57 PM
  • My issue was that I wasn't running the Report Server as NETWORK SERVICE.
    Tuesday, August 10, 2010 3:39 AM
  • Make sure you have completed the Report Server configuration,  including the creation of ReportServer Database.

    And run SSRS service using Network Service.

    Monday, November 15, 2010 10:08 PM
  • Greg,

    I think most of the posts under this question are people having issues after configuring SSRS in native mode.  I actually ran into this issue again today and had to do some additional steps to resolve it.  Unfortunately we tried a couple different things so I don't know exactly what fixed it.  Here are the steps I performed.

    The first thing I noticed was the domain account running all of the SQL Server services wasn't SA in SQL Server.  I granted the service account as sysadmin.

    This didn't fix it.

    I deleted the reports databases and recreated them liked I outlined above.

    This still didn't fix it.

    I updated the password for the service account to make sure it was correct.  I don't think this was an issue because the service was running, but I included the step.

    The last thing I did was notice that the service user account as in the format username@domain.com.  Inside of the SSRS Configuration Tool, it complained about this.  I changed the format to DOMAIN\username in the services administration screen and restarted the service.

    This fixed the error and the verify and configuration of TFS 2010 was successful.

    I hope this helps

    Mike


    blog - http://www.codesmartnothard.com
    Wednesday, June 29, 2011 4:09 AM
  • Thank you! This worked for me as well.
    Tuesday, August 2, 2011 3:37 AM
  • Hello

    if your recieve the following error :
    TF255275: The following Web service for SQL Server Reporting Services could not be accessed: http://yoursqlserver/ReportServer/ReportService2005.asmx


    Here is how to solve it :

    1) go to the sql server instance
    2) click start, then all programs and choose microsft sql server 2008 R2
    3) open configuration tools and choose Reporting Services Configuration management
    4) make sure that the server name is right, that the account used is the right one
    5) click on Report manager URL make sure that "http://yoursqlserver:80/reports" is working
    6) if you did that go back run your TFS configuration wizard all will work fine

    Cheers

    Wednesday, December 21, 2011 9:03 PM
  • Thanks.. This helps.

    Monday, April 2, 2012 5:19 AM