locked
While trying to generate the APK from MAC getting this issue RRS feed

  • Question

  • User328463 posted

    APK got generating successfully, but when trying to install through adb install, getting this error.

    Failure [INSTALLPARSEFAILEDNOCERTIFICATES: Failed to collect certificates from /data/app/vmdl1259146880.tmp/base.apk: META-INF/INFORCON.SF indicates /data/app/vmdl1259146880.tmp/base.apk is signed using APK Signature Scheme v2, but no such signature was found. Signature stripped?]

    Visual Studio Community 2017 for Mac Version 7.6 (build 2190) Installation UUID: 6425ee7e-e216-425f-be84-ade4fa8c3f01 Runtime: Mono 5.10.1.57 (2017-12/ea8a24b1bbf) (64-bit) GTK+ 2.24.23 (Raleigh theme) Xamarin.Mac 4.4.1.178 (master / eeaeb7e6)

    Package version: 510010057
    

    Xamarin.Android Version: 9.0.0.18 (Visual Studio Community) Android SDK: /Users/skondi/Library/Developer/Xamarin/android-sdk-macosx Supported Android versions: 7.1 (API level 25) 8.0 (API level 26) 8.1 (API level 27)

    Operating System Mac OS X 10.13.6 Darwin 17.7.0 Darwin Kernel Version 17.7.0 Thu Jun 21 22:53:14 PDT 2018 root:xnu-4570.71.2~1/RELEASEX8664 x86_64

    Thursday, August 23, 2018 2:49 PM

All replies

  • User367149 posted

    I'm getting exactly the same error since updating:

    You uploaded an APK with an invalid signature (learn more about signing). Error from apksigner: ERROR (Jar signerXXX.RSA): JAR signature META-INF/E-ROUTE_.SF indicates the APK is signed using APK Signature Scheme v2 but no such signature was found. Signature stripped

    Friday, August 24, 2018 9:55 AM
  • User367149 posted

    Found this to be the solution: https://stackoverflow.com/questions/51679077/error-signing-and-uploading-apk-on-xamarin-android-9-and-visual-studio-for-mac-b

    The signing tool in xamarin studio seems to be buggered, you need to sign it via terminal for now :(

    Friday, August 24, 2018 10:27 AM
  • User38123 posted

    Manually signing the apk worked for me with zipalign. This is a pretty bad bug, no one developing for Android can generate release apk's using the latest IDE. It shows that the Xamarin developers and QA team don't actually develop their own real apps, they only test in debug mode, otherwise this would have been caught.

    Friday, August 24, 2018 1:28 PM
  • User169159 posted

    Same thing.

    Monday, August 27, 2018 10:04 AM
  • User354376 posted

    Same thing here :disappointed:

    Also tried with version Version 7.7 Preview (build 977) that has a fix for apk signing, but it still doesn't work

    Wednesday, August 29, 2018 9:43 AM
  • User125151 posted

    Same here. Hope a new release fixing the bug is released shortly

    Thursday, August 30, 2018 7:37 AM