locked
Illegal characters in path when loading string into XmlDoc RRS feed

  • Question

  • Hi Everyone,

    I'm attempting to create an XmlDoc from a string loaded with a portion of XML that has been retrieved from a Web Response.

    The portion of XML:


    <?xml version="1.0" ?>
    
    - <rmlResults>
    
    - <GetDateRange>
    
    - <firstDate>
    
      <y>1997</y>
    
      <m>5</m>
    
      <d>6</d>
    
      <j>2450575</j>
    
      <ymd>19970506</ymd>
    
      </firstDate>
    
    - <lastDate>
    
      <y>2009</y>
    
      <m>7</m>
    
      <d>1</d>
    
      <j>2455014</j>
    
      <ymd>20090701</ymd>
    
      </lastDate>
    
      </GetDateRange>
    
      <warningList />
    
      <errorList />
    
      <fatalErrorList />
    
      <millisInQueue>0</millisInQueue>
    
      <millisInProcess>31</millisInProcess>
    
      <physicalMemInUse>21986500608</physicalMemInUse>
    
      <engineVersion>4,8,4,13</engineVersion>
    
      <computer>AB-RM-U-RS84</computer>
    
      <computerAndPort>AB-RM-U-RS84:9038</computerAndPort>
    
      <loadTimeInMillis>0</loadTimeInMillis>
    
      <queryLen>305</queryLen>
    
      <queryId>tag:kchopra,2009-7-2:excelRibbon,6338214926855942/10.42.13.254:10437078274437764</queryId>
    
      <resultLen>751</resultLen>
    
      </rmlResults>
    

    As far as I can tell, this is a legitimate portion of XML. However when attempting to load this into an XmlDoc, i get an ArgumentException "illegal Characters in path"

    XmlDocument xmlDoc = new XmlDocument();
    xmlDoc.Load(stringwithportionofXML);

    I'm not sure what could be causing this...any help would be great!

    Kind Regards

    Kevin.
    Thursday, July 2, 2009 3:58 PM

Answers

All replies