locked
Setup MS Lightswitch Issue Tracker RRS feed

  • Question

  • I have the MS Visual Studio Lightswitch 2011 version. I have been able to connect to my SQL Server 2008 Express databases fine. In fact i have started building screens based on the Northwind database to test functionality out. No problems there.

    However I tried running the IssueTracker Starter Kit without success. I keep getting the following error:

    Microsoft.LightSwitch.DataServiceOperationException was unhandled by user code
      Message=The underlying provider failed on Open.
    Inner exception message:
    A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)

    The main window comes up but the app will not connect to the database. can anyone assist?

    Thursday, January 10, 2013 9:15 PM

Answers

  • Fixed. I uninstalled SQL Server 2008, then Lightswitch. Rebooted and re-installed Lighswitch and now I can run the starter kits.

    • Marked as answer by LeeHman Saturday, January 12, 2013 4:10 PM
    Saturday, January 12, 2013 4:10 PM

All replies

  • From which link did you download the issue tracker?
    Thursday, January 10, 2013 9:18 PM
  • I used 'New Project' then 'Online Templates'. I downloaded from the MS website inside the IDE.
    Thursday, January 10, 2013 11:56 PM
  • The reason I am asking is that the tracker application may access the database differently between the different versions of lightswitch. From what I understand it uses express in 2011 byt localdb in 2012. Will have to check on that though.
    Friday, January 11, 2013 1:16 AM
  • here's a copy of the app.config (appears to use sql express):

     <connectionStrings>
            <add name="LightSwitchConnectionString"
                connectionString="Data Source=.\SQLEXPRESS;AttachDbFilename=&quot;|DataDirectory|\Data\DevelopmentDatabase.mdf&quot;;Integrated Security=True;User Instance=True;MultipleActiveResultSets=True;Pooling=False;"
                providerName="System.Data.SqlClient" />
        </connectionStrings>

    Friday, January 11, 2013 1:04 PM
  • Fixed. I uninstalled SQL Server 2008, then Lightswitch. Rebooted and re-installed Lighswitch and now I can run the starter kits.

    • Marked as answer by LeeHman Saturday, January 12, 2013 4:10 PM
    Saturday, January 12, 2013 4:10 PM